This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 855346 - excessive dependencies
excessive dependencies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pygobject3 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks: depchain 854355 874378 874480 1242076
  Show dependency treegraph
 
Reported: 2012-09-07 09:29 EDT by Bill Nottingham
Modified: 2015-07-10 16:04 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 874480 (view as bug list)
Environment:
Last Closed: 2012-12-18 01:51:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2012-09-07 09:29:11 EDT
Description of problem:

firewalld uses gi/gobject. This isn't in and of itself a problem.

However, using this leads to a dep on pygobject3, which starts bringing in:
- cairo
- xcb
- fontconfig
- Mesa
- libX11
etc.

all from firewalld just wanting to use the mainloop and the Gio file monitor.

Version-Release number of selected component (if applicable):

3.3.4-8.fc18

How reproducible:

100%

Steps to Reproduce:
1. yum groupinstall core standard
  
Actual results:

Hey, where did the GUI stuff come from?
Comment 1 Bill Nottingham 2012-09-07 09:45:21 EDT
Looks like it can be 'fixed' by subpackaging out /usr/lib64/python2.7/site-packages/gi/_gi_cairo.so into a different package.
Comment 2 Tomas Mraz 2012-11-08 07:28:33 EST
Do we know which packages require the python Cairo gi? As these would have to be changed to require the subpackage.
Comment 3 Colin Walters 2012-11-08 12:21:52 EST
It's worth noting that pygobject already has a build-time option to disable the cairo bindings; that helps people building embedded systems and the like.

I'm not sure though if there's much to do upstream to help - I doubt it's worth having a properly defined/documented extension mechanism just for this, since cairo is a special case; the combination of gobject-introspection/pygobject are the generic plugin system basically.
Comment 4 Fedora Update System 2012-12-13 12:40:28 EST
pygobject3-3.4.2-4.fc18,firewalld-0.2.11-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pygobject3-3.4.2-4.fc18,firewalld-0.2.11-2.fc18
Comment 5 Fedora Update System 2012-12-14 01:44:50 EST
Package pygobject3-3.4.2-4.fc18, firewalld-0.2.11-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pygobject3-3.4.2-4.fc18 firewalld-0.2.11-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20311/pygobject3-3.4.2-4.fc18,firewalld-0.2.11-2.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-12-18 01:51:18 EST
pygobject3-3.4.2-4.fc18, firewalld-0.2.11-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.