Bug 855365 - New String: Unique Output String When CLI Unsubscribe --all From 1 Subscription
New String: Unique Output String When CLI Unsubscribe --all From 1 Subscription
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
Entitlement Bugs
:
Depends On:
Blocks: 771481 840993
  Show dependency treegraph
 
Reported: 2012-09-07 10:15 EDT by Matt Reid
Modified: 2013-02-21 03:56 EST (History)
3 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:56:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-09-07 10:15:38 EDT
Description of problem:
When you unsubscribe using "subscription-manager unsubscribe --all" from 1 subscription, our current output string is "This machine has been unsubscribed from 1 subscriptions". While this works great for if there are 2 or more subscriptions that were just unsubscribed, it would be nice if we had a unique string for when subscriptions shouldn't be plural.

Desired Output:
"This machine has been unsubscribed from 1 subscription"

Version-Release number of selected component (if applicable):
1.0.17-1
Comment 1 Bryan Kearney 2012-10-12 09:50:32 EDT
fixed in master at 3587a47789206bb22329d4af165350b573ab2923
Comment 5 Shwetha Kallesh 2012-11-06 02:38:02 EST
Verified!!

[root@rhel-64-server ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.7.17-1
subscription-manager: 1.1.5-1.el6
python-rhsm: 1.1.4-1.el6


[root@rhel-64-server ~]# subscription-manager subscribe --pool 8ac6a3db3abfc2ed013abfc3a431023b
Successfully consumed a subscription for: Shared File System

[root@rhel-64-server ~]# subscription-manager unsubscribe --all
This machine has been unsubscribed from 1 subscription.
Comment 7 errata-xmlrpc 2013-02-21 03:56:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.