Bug 855389 - CreateException: Can't have a partition outside the disk!
CreateException: Can't have a partition outside the disk!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:9b4dbc49da4840cec4a2a80651f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 11:05 EDT by kevin martin
Modified: 2012-11-22 20:35 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 20:35:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: ifcfg.log (697 bytes, text/plain)
2012-09-07 11:05 EDT, kevin martin
no flags Details
File: anaconda-tb (388.29 KB, text/plain)
2012-09-07 11:05 EDT, kevin martin
no flags Details
File: environ (757 bytes, text/plain)
2012-09-07 11:05 EDT, kevin martin
no flags Details
File: type (9 bytes, text/plain)
2012-09-07 11:05 EDT, kevin martin
no flags Details
File: storage.log (146.56 KB, text/plain)
2012-09-07 11:05 EDT, kevin martin
no flags Details
File: version (2 bytes, text/plain)
2012-09-07 11:05 EDT, kevin martin
no flags Details
File: program.log (70.12 KB, text/plain)
2012-09-07 11:05 EDT, kevin martin
no flags Details
File: product (6 bytes, text/plain)
2012-09-07 11:06 EDT, kevin martin
no flags Details
File: syslog (121.25 KB, text/plain)
2012-09-07 11:06 EDT, kevin martin
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-09-07 11:06 EDT, kevin martin
no flags Details
File: anaconda.log (15.14 KB, text/plain)
2012-09-07 11:06 EDT, kevin martin
no flags Details
File: release (24 bytes, text/plain)
2012-09-07 11:06 EDT, kevin martin
no flags Details
File: description (1.61 KB, text/plain)
2012-09-07 11:06 EDT, kevin martin
no flags Details

  None (edit)
Description kevin martin 2012-09-07 11:05:38 EDT
Version-Release number of selected component:
anaconda-18.6.5

Additional info:
libreport version: 2.0.12
cmdline:        initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2018\x20x86_64 quiet nouveau.modeset=0 vesa BOOT_IMAGE=vmlinuz 
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64
Comment 1 kevin martin 2012-09-07 11:05:48 EDT
Created attachment 610765 [details]
File: ifcfg.log
Comment 2 kevin martin 2012-09-07 11:05:51 EDT
Created attachment 610766 [details]
File: anaconda-tb
Comment 3 kevin martin 2012-09-07 11:05:52 EDT
Created attachment 610767 [details]
File: environ
Comment 4 kevin martin 2012-09-07 11:05:54 EDT
Created attachment 610768 [details]
File: type
Comment 5 kevin martin 2012-09-07 11:05:56 EDT
Created attachment 610769 [details]
File: storage.log
Comment 6 kevin martin 2012-09-07 11:05:58 EDT
Created attachment 610770 [details]
File: version
Comment 7 kevin martin 2012-09-07 11:05:59 EDT
Created attachment 610771 [details]
File: program.log
Comment 8 kevin martin 2012-09-07 11:06:01 EDT
Created attachment 610772 [details]
File: product
Comment 9 kevin martin 2012-09-07 11:06:03 EDT
Created attachment 610773 [details]
File: syslog
Comment 10 kevin martin 2012-09-07 11:06:04 EDT
Created attachment 610774 [details]
File: hashmarkername
Comment 11 kevin martin 2012-09-07 11:06:06 EDT
Created attachment 610775 [details]
File: anaconda.log
Comment 12 kevin martin 2012-09-07 11:06:07 EDT
Created attachment 610776 [details]
File: release
Comment 13 kevin martin 2012-09-07 11:06:09 EDT
Created attachment 610777 [details]
File: description
Comment 14 David Lehman 2012-09-07 13:32:09 EDT
10:04:54,378 DEBUG anaconda: populate_right_side: existing 10751MB partition sda3 (5) with existing ntfs filesystem
10:04:54,384 DEBUG anaconda: min: 10886  max: 16777216  current: 10751.0

Looks like NTFS.minSize is telling us a value larger then the block device's current size in spite of this:

10:01:20,873 INFO program: Running... ntfsresize -m /dev/sda3
10:01:21,020 INFO program: ntfsresize v2012.1.15 (libntfs-3g)
10:01:21,021 INFO program: Minsize (in MB): 10636
Comment 15 David Lehman 2012-09-07 14:21:24 EDT
Apparently we have some ancient code that adds 250 MB to the minimum size reported by ntfsresize -m. That's how the minimum size ends up greater than the current size. Now to figure out whether to keep that and, if so, how to deal with such nonsense.
Comment 17 David Lehman 2012-10-11 11:21:31 EDT
This should be fixed in anaconda-18.13-1.
Comment 18 Adam Williamson 2012-11-22 20:35:52 EST
This bug looks to have been fixed for many anaconda builds now but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

Note You need to log in before you can comment on or make changes to this bug.