This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 855416 - regression: chown does not work in NFS4
regression: chown does not work in NFS4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Steve Dickson
Yin.JianHong
: Regression, ZStream
Depends On: 849945 1020653
Blocks: 823848
  Show dependency treegraph
 
Reported: 2012-09-07 12:40 EDT by RHEL Product and Program Management
Modified: 2014-01-15 07:34 EST (History)
9 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-15.el6_2.2
Doc Type: Bug Fix
Doc Text:
Due to a regression, the NFSv4 idmapper utility did not initialize correctly, which lead to a creation of incorrect file permissions. With this update, idmapper initializes as expected, creating correct file permissions.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 07:29:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The patch that fixes the problem (825 bytes, patch)
2012-10-10 14:11 EDT, Steve Dickson
no flags Details | Diff

  None (edit)
Description RHEL Product and Program Management 2012-09-07 12:40:04 EDT
This bug has been copied from bug #849945 and has been proposed
to be backported to 6.2 z-stream (EUS).
Comment 5 Steve Dickson 2012-10-10 14:11:26 EDT
Created attachment 625074 [details]
The patch that fixes the problem
Comment 10 Yin.JianHong 2013-10-22 05:51:29 EDT
verify by :
https://beaker.engineering.redhat.com/jobs/524526
   6.2 test PASS

https://beaker.engineering.redhat.com/jobs/524558
   6.2 + errata, test FAIL;

:: [   FAIL   ] :: Test root hasn't privilege to chown its file since squash to nobody (Expected 1, got 0)
----------------------------------------------------------------
6.2 is OK, why  backported to 6.2 z-stream?
Comment 11 Yin.JianHong 2013-10-31 03:51:13 EDT
Hi all
    this bug is not in RHEL6.2, no need a zstream errata for 6.2;
    I think we should close this bug, and delete the errata.
Comment 12 Steve Dickson 2013-11-20 08:29:41 EST
(In reply to Yin.JianHong from comment #11)
> Hi all
>     this bug is not in RHEL6.2, no need a zstream errata for 6.2;
>     I think we should close this bug, and delete the errata.

Here is the patch that went in:

diff -up nfs-utils-1.2.3/utils/idmapd/idmapd.c.orig nfs-utils-1.2.3/utils/idmapd/idmapd.c 
--- nfs-utils-1.2.3/utils/idmapd/idmapd.c.orig  2012-10-10 11:23:46.229652000 -0400
+++ nfs-utils-1.2.3/utils/idmapd/idmapd.c       2012-10-10 13:36:31.164381000 -0400
@@ -836,7 +836,7 @@ nametoidres(struct idmap_msg *im)
 
        switch (im->im_type) {
        case IDMAP_TYPE_USER:
-               ret = nfs4_name_to_uid(im->im_name, &uid);
+               ret = nfs4_owner_to_uid(im->im_name, &uid);
                im->im_id = (u_int32_t) uid;
                if (ret) {
                        im->im_status = IDMAP_STATUS_LOOKUPFAIL;
@@ -844,7 +844,7 @@ nametoidres(struct idmap_msg *im)
                }
                return;
        case IDMAP_TYPE_GROUP:
-               ret = nfs4_name_to_gid(im->im_name, &gid);
+               ret = nfs4_group_owner_to_gid(im->im_name, &gid);
                im->im_id = (u_int32_t) gid;
                if (ret) {
                        im->im_status = IDMAP_STATUS_LOOKUPFAIL;

This allows clients to understand uid/gid strings that are returned by the server in both the "3606" format and "steved@redhat.com" format.
Comment 13 Jan Kurik 2014-01-15 07:29:52 EST
(In reply to Yin.JianHong from comment #11)
> Hi all
>     this bug is not in RHEL6.2, no need a zstream errata for 6.2;
>     I think we should close this bug, and delete the errata.

Checked with Steve Dickson - I am closing the bug and removing the errata.

Note You need to log in before you can comment on or make changes to this bug.