Bug 855427 - JBoss cartridges: can't change JBoss modules
JBoss cartridges: can't change JBoss modules
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 13:24 EDT by Nam Duong
Modified: 2015-05-14 18:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 14:32:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-09-07 13:24:36 EDT
Description of problem:

See forum thread: https://openshift.redhat.com/community/forums/openshift/possible-to-change-jboss-modules

"I have a java web application running on the jboss as cartridge. I'm using the seam framework, which uses picketlink. Due to a problem in the jboss picketlink module, i cannot run my application, unless I change this module (as defined here: https://community.jboss.org/wiki/HowToConfigurePicketLink202WithJBossAS711). Is this possible? If yes, how?"

https://community.jboss.org/wiki/HowToConfigurePicketLink202WithJBossAS711 documents a workaround which requires the user to modify ${jboss.home.dir}/modules/org/picketlink but it's read-only.

Any chance we can change it to read/write so that users can enable seam apps with picketlink?
Comment 1 Bill DeCoste 2012-09-07 14:32:37 EDT
You can override the default modules via the git repo at .openshift/config/modules. I'll comment this on the forum post.

Note You need to log in before you can comment on or make changes to this bug.