Bug 855451 - libgpg-error should build static libs for gpgme unit testing
libgpg-error should build static libs for gpgme unit testing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgpg-error (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 855454 858512
  Show dependency treegraph
 
Reported: 2012-09-07 15:41 EDT by John Morris
Modified: 2012-09-26 01:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 858512 (view as bug list)
Environment:
Last Closed: 2012-09-25 02:46:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to reenable building static libs in libgpg-error-devel RPM (1.99 KB, patch)
2012-09-07 15:41 EDT, John Morris
no flags Details | Diff

  None (edit)
Description John Morris 2012-09-07 15:41:47 EDT
Created attachment 610833 [details]
Patch to reenable building static libs in libgpg-error-devel RPM

The libgpg-error-devel RPM does not contain %{_libdir}/libgpg-error.a, needed by gpgme to run the basic gpg unit tests.

gpgme unit tests would currently fail, except they've been disabled because they won't build without these static libs.  (Soon will file a ticket dependent on this bug.)

I'm attaching a patch to re-enable building the static libs.

The patch also updates .gitignore to ignore fedpkg local build artifacts.
Comment 1 Tomas Mraz 2012-09-19 03:04:32 EDT
Could the tests in gpgme be patched to use the shared library? I'd like to avoid shipping static libraries just for tests of gpgme. Also the patch is not correct as it does not comply with the packaging guidelines in regards to static libraries.
Comment 2 John Morris 2012-09-24 23:51:20 EDT
Sorry for not getting back earlier.

I'm ambivalent as to what package maintainers finally decide upon.  I don't like shipping static libs just for this purpose, either.  On the other hand, I think gpgme ought to run its unit tests, and especially if it's failing some of them.

The package can be patched to use the shared library; that's how I first got the tests to work.  If that's acceptable within the guidelines, it sounds like a nice workaround.  (Still new to those guidelines; I don't mind doing the work for this fix, but appreciate advice on what's acceptable and what's not!)

    John
Comment 3 Tomas Mraz 2012-09-25 02:46:24 EDT
Patching gpgme to use shared libraries for tests is definitely acceptable and within guidelines.
Comment 4 John Morris 2012-09-26 01:55:23 EDT
Bug #855454:  a patch to the gpgme package to link against shared libs has been submitted.  Thanks-

    John

Note You need to log in before you can comment on or make changes to this bug.