Bug 855453 - libvirt 0.9.11.5-3 fills message log VERY fast
libvirt 0.9.11.5-3 fills message log VERY fast
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: netcf (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-07 15:47 EDT by Corinna Vinschen
Modified: 2012-10-14 23:40 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-14 23:40:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corinna Vinschen 2012-09-07 15:47:08 EDT
Description of problem:

  The latest F17 update of libvirt, version 0.9.11.5-3, introduced a new
  problem which results in flooding the syslog.  With the former version
  0.9.11.3-1 I got a single message in the log when starting
  virt-manager:

    error : virInterfaceDefParseXML:794 : XML error: bond interface misses
    the bond element

  Starting with version 0.9.11.5-3, this message also shows up as soon
  as I start virt-manager, but then it floods the syslog, one message 
  each second, until virt-manager exits.

  This reminds me a lot of a similar problem with virt-manager flooding
  the syslog in F14:

    https://bugzilla.redhat.com/show_bug.cgi?id=698108

  The setup of the host hasn't changed.  The server has two NICs, eth0
  and eth1, which are bonded as bond0.  On top of that sits a bridge
  interface br0 with v4 and v6 address and a br0:1 with a second v4
  address. 

  This setup works flawlessly for about 3 years now, and I have no idea
  what libvirt is trying to tell me with the aforementioned message.
  Since this was never a problem I could simply ignore the message, but
  I can't ignore it if it floods the syslog.

Version-Release number of selected component (if applicable):

  0.9.11.5-3

How reproducible:

  I don't know exactly since I don't know what libvirt is complaining
  about.


Actual results:

  Every second in the syslog:

    libvirtd[19651]: 2012-09-07 18:33:48.589+0000: 19655: error :
    virInterfaceDefParseXML:794 : XML error: bond interface misses the
    bond element

Expected results:

  Silence.  No useless syslog entry since everything works as expected.


Thanks,
Corinna
Comment 1 Laine Stump 2012-09-11 10:46:56 EDT
What is the version of the netcf-libs package? If it is 0.1.9, please update to netcf-0.2.2-1 from the updates-testing repo and see if that solves the problem. If that solves the problem, this is a duplicate of Bug 855572.

(Since the bug was files on Sept 7, and the new netcf-libs package wasn't put in updates-testing until Sept 9, I'm guessing this is the case).

The only surprising part is that it didn't complain previously. Did you possibly not have a bond interface before, and have just recently added one?
Comment 2 Laine Stump 2012-09-11 11:18:40 EDT
BTW, if the new netcf build fixes your problem and you have a fedoraproject account, please visit https://admin.fedoraproject.org/updates/netcf-0.2.2-1.fc17 login, and leave a comment with positive karma to help it get to stable sooner.
Comment 3 Corinna Vinschen 2012-09-11 12:43:09 EDT
Hi Laine,

I'm sorry if my bug report wasn't clear enough.  I always had a bond
interface.  The difference between earlier libvirt and libvirt-0.9.11.5-3
is that the earlier version only reported the "bond interface misses the
bond element" message exactly once when starting virt-manager, while with 0.9.11.5-3 the message showed up every second, thus flooding the syslog
with useless messages.

On the bright side, yes, my netcf-libs was 0.1.9 and updating to 0.2.2-1
the "bond ..." message disappeared entirely.

However, I'm still wondering if there isn't a related bug in libvirt which
is now covered by the netcf-libs fix.  The fact that the message was only
sent to the syslog once with libvirt 0.9.11.3-1, but is now sent to the
syslog every second, sounds fishy to me.

Anyway, thanks for the reply and the netcf fix.  I'll make sure to leave
positive karma.


Corinna
Comment 4 Fedora Update System 2012-09-18 06:17:25 EDT
netcf-0.2.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-13735/netcf-0.2.2-1.fc17

Note You need to log in before you can comment on or make changes to this bug.