Bug 855481 - Root password is empty after install from live image without completing root pw spoke in anaconda
Root password is empty after install from live image without completing root ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedNTH RejectedBlocker
: Reopened
Depends On:
Blocks: F18Alpha-accepted/F18AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-07 19:44 EDT by Adam Williamson
Modified: 2012-10-23 10:19 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-23 10:19:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-09-07 19:44:28 EDT
I just built an Xfce live image with anaconda 18.6.6 for some smoke testing. I did an install to disk without entering the 'root password' spoke. I'd expect that the installed system would have an inaccessible root account, as is the case for a netinst/DVD install if you don't complete the root pw spoke, but that isn't the case: the root password is empty, like in the pre-install live environment. You can become root just by typing 'su'. Obviously, this isn't how we want it to work.

Proposing as blocker for Alpha as bcl suggests it ought to be blocker, but I'm not so sure, it doesn't actually *break* anything in the criteria, and you damn well shouldn't install Alpha on production systems anyhow.
Comment 1 Adam Williamson 2012-09-07 21:00:36 EDT
In fact, the root password seems to be empty post-install whether you complete the spoke or not, anaconda's simply failing to set it at all. bcl is investigating.
Comment 2 Brian Lane 2012-09-07 21:11:07 EDT
libuser appears to be ignoring the LIBUSER_CONF variable, it is setting the root password on /etc/shadow instead of /mnt/sysimage/etc/shadow. I'm not sure why yet.
Comment 3 Brian Lane 2012-09-08 01:14:09 EDT
LIBUSER_CONF needs to be set before calling User()
Comment 4 Adam Williamson 2012-09-10 12:14:39 EDT
Discussed at 2012-09-10 QA meeting acting as a blocker review meeting. Though we're slightly uncomfortable with it, we decided for now that this doesn't meet the criteria precisely and so we accept it as NTH but reject as blocker. We may re-visit this decision later.
Comment 5 Fedora Update System 2012-09-10 15:28:43 EDT
anaconda-18.6.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.6.7-1.fc18
Comment 6 Fedora Update System 2012-09-11 15:11:38 EDT
Package anaconda-18.6.7-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.6.7-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13805/anaconda-18.6.7-1.fc18
then log in and leave karma (feedback).
Comment 7 Adam Williamson 2012-09-12 02:35:06 EDT
This is fixed in Alpha RC2.
Comment 8 Fedora Update System 2012-09-12 16:36:36 EDT
anaconda-18.6.7-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Akira TAGOH 2012-09-25 04:32:31 EDT
This issue seems still there. I tried the install from live image, http://adamwill.fedorapeople.org/graphics_test_week_20120924/20120924-test_days-x86_64.iso and set root password during the installation. once it's finished, boot. gdm didn't ask the root password when I type "root" as the user.

the password field in /etc/shadow is empty for root.
Comment 10 Adam Williamson 2012-09-25 12:22:42 EDT
I can't reproduce this. I just tested it myself and my root password was properly set.

Did you click the 'Done' button after entering and confirming the root password? Just leaving the screen sitting there would not be enough, I don't think.
Comment 11 Akira TAGOH 2012-09-26 03:20:30 EDT
Of course I did and I can see "Root password is set" message there. but the root password is still empty in /etc/shadow.
Comment 12 Akira TAGOH 2012-09-26 03:55:15 EDT
After "reboot" screen appears, tried to see how is /etc/shadow. and realized that anaconda changed the root password in "/etc/shadow" but /mnt/sysimage/etc/shadow as it mentioned at comment#2. anaconda --version gives me "anaconda 18.8".
Comment 13 Brian Lane 2012-09-27 12:46:28 EDT
Moving the root password setup to the progress hub broke this. Patch sent.
Comment 14 Fedora Update System 2012-10-02 10:12:54 EDT
anaconda-18.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.11-1.fc18
Comment 15 Fedora Update System 2012-10-02 15:47:22 EDT
Package anaconda-18.11-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.11-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15207/anaconda-18.11-1.fc18
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-10-03 20:57:41 EDT
anaconda-18.12-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.12-1.fc18
Comment 17 Kamil Páral 2012-10-23 10:19:19 EDT
Anaconda 18.19 now correctly sets root password when installing from Live. Closing.

Note You need to log in before you can comment on or make changes to this bug.