Bug 855495 - Alias system pip CLI from pip-python to python-pip
Alias system pip CLI from pip-python to python-pip
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-pip (Show other bugs)
17
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tim Flink
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-08 01:27 EDT by Nick Coghlan
Modified: 2012-12-06 23:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-06 23:28:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Coghlan 2012-09-08 01:27:52 EDT
To avoid a nameclash with perl-pip (I assume), the python-pip package installs the CLI as "pip-python" rather than as "pip".

By contrast, perl-pip uses the same name for both the package *and* the CLI.

The reversal in the Python version (package python-pip, CLI pip-python) seems unnecessarily confusing. It would be easier to remember if the CLI used the same order as the package.
Comment 1 Nick Coghlan 2012-09-08 01:36:30 EDT
Changed suggestion to aliasing, since an abrupt rename would break scripts that expect the reversed name on Fedora.
Comment 2 Tim Flink 2012-09-13 01:31:07 EDT
I guess that I hadn't really looked at the differences between perl-pip and python-pip all that much or noticed the discrepancy between the package and binary name.

I have a bunch of packaging work to do as soon as F18 alpha is released - I'll add the alias then and leave both of them for a couple of releases before phasing it out for F19 or F20.
Comment 3 Fedora Update System 2012-10-09 15:21:34 EDT
python-pip-1.2.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-pip-1.2.1-2.fc18
Comment 4 Fedora Update System 2012-10-10 01:03:43 EDT
Package python-pip-1.2.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-pip-1.2.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15769/python-pip-1.2.1-2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-06 23:28:26 EST
python-pip-1.2.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.