Bug 8555 - cannot mount nfs filesystems from AIX, Solaris, IRIX or HP-UX
cannot mount nfs filesystems from AIX, Solaris, IRIX or HP-UX
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-17 20:10 EST by david
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 14:14:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david 2000-01-17 20:10:41 EST
In a heterogeneous environment, where AIX, Solaris, IRIX, HP-UX
and Debian workstations are sharing NFS partitions, the Red Hat 6.1 box
can mount ONLY the partitions from the Debian boxes.  All other machines
are cross mounting partitions without any problems.

We have the 2.2.14 kernel and are running knfsd-1.4.7-7 and
knfsd-clients-1.4.7-7.  The kernel has been compiled with full NFS support
and all relevant daemons are running.  I am able to mount NFS filesystems
from Debian 2.0 and 2.1 boxes, and am able to export the Red Hat 6.1
filesystems to all other platforms.  However, when I try to mount a NFS
partition from a AIX, Solaris, IRIX or HP-UX box it complains with error:

mount: wrong fs type, bad option, bad superblock on
mymachine.mydomain.com:/export, or too many mounted file systems

I have some general posts of this type on www.deja.com but no relevant
responses.  Can you suggest a patch to try or a workaround?  Is there any
information on when this might be fixed?
Comment 1 Jeff Johnson 2000-01-18 12:59:59 EST
Make sure that you are using NFSv2. Your /etc/rc.d/init.d/nfs should have

# No NFS V3.
RPCMOUNTDOPTS="--no-nfs-version 3"

# See how we were called.
case "$1" in
  start)
        # Start daemons.
        action "Starting NFS services: " /usr/sbin/exportfs -r
        echo -n "Starting NFS quotas: "
        daemon rpc.rquotad
        echo
        echo -n "Starting NFS mountd: "
        daemon rpc.mountd $RPCMOUNTDOPTS

In addition, you should make sure that rpc.lockd is started before nfs.
Comment 2 Mike Schwarz 2000-02-11 20:23:59 EST
We had similar problems mounting a HP-UX 11.0 filesystem to RedHat 6.0 and 6.1
but HP-UX 10.20 worked fine.  This was fixed in newer HP patches.
Comment 3 david 2000-02-12 15:14:59 EST
It turns out that the magic is to make sure you explicitly pass in
the vers=2 option to mount (i.e.  mount -o vers=2  ...)
or, if using autofs like us, is edit
/etc/rc.d/init.d/autofs,
and add localoptions add "vers=2"
Comment 4 Cristian Gafton 2000-08-08 22:34:28 EDT
assigned to johnsonm
Comment 5 Peter L. Thomas 2001-07-12 14:13:58 EDT
Does this mean that heterogenous environments can only use v2?  One solution I
found was to use the -n option on the foreign mountd configuration.  Is that  a
substantial security concern?  Is using NFSv2 a performance or security "hit"
versus v3?
Comment 6 Michael K. Johnson 2001-07-12 14:24:28 EDT
Our 2.2.19-based errata kernel has support for NFSv3

Note You need to log in before you can comment on or make changes to this bug.