Bug 85550 - Change several bugs at once has problems
Summary: Change several bugs at once has problems
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Bugzilla General   
(Show other bugs)
Version: 3.2
Hardware: i386
OS: Linux
medium
low vote
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: David Lawrence
URL: buglist.cgi?bug_status=NEW&bug_status...
Whiteboard:
Keywords:
: 85633 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-04 09:03 UTC by sand
Modified: 2013-06-24 03:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-28 20:40:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sand 2003-03-04 09:03:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.22; Mac_PowerPC)

Description of problem:
query bugzilla such that it generates a list of more than six bugs (i've only 
seen this problem happen with a list of more than six).

click on the "change several bugs at once" link.

bugzilla doesn't respond. on browsers which have a progress indicator, the 
indicator implies about 20% complete and stays that way forever. the browser 
rendering area is blank. the cursor indicates "busy."

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. query bugzilla so that it generates a list of more than six bugs.
2. click on the "change several bugs at once" link.

Actual Results:  bugzilla doesn't respond. on browsers which have a progress 
indicator, the indicator implies about 20% complete and stays that way forever. 
the browser rendering area is blank. the cursor indicates "busy."

Expected Results:  the same list of bugs should appear (as in step 1), but with 
checkboxes in front of each, and various available alterations with which to 
apply to those bugs which you check.

Additional info:

if this isn't reproducible, you can try it on http://bugreports.gizmolab.com

Comment 1 David Lawrence 2003-03-04 16:26:40 UTC
The URL you provided is very general and will return a VERY large result set and
will take quite a while to generate the results page. It will literally return
several thousand bugs. I need to add some checks in the code to error out for
this in the near future. Will you please select a product or two and maybe a
component and re-run your query. I am able to get the "Change Several Bugs at
Once" to work fine on all of the smaller sets of 100 or more bugs.

Comment 2 David Lawrence 2003-03-10 04:55:40 UTC
*** Bug 85633 has been marked as a duplicate of this bug. ***

Comment 3 sand 2003-03-10 09:23:24 UTC
It fails for me, on my site, in a semi-private area, in exactly the way I described initially, with merely seven bugs in the list. This is the simplest black box test I can think of to trigger the symptom. Please contact me directly (sand@gizmolab.com) and I can somehow (we can think of some way to) arrange a demonstration.

I've been trying to tinker with the code to get it to work, but I frankly can't quite get the gestalt of this perl script (buglist.cgi).

I kinda gave up and am trying to get version 2.17 to work, but the schema has so radically shifted, and I have been working with rhdb 2.1 (a natural choice, eh?) which is essentially postgresql 7.2.3 and I need 7.3 in order to add such things as primary key, because they can only be applied to a not null int, which can't be added, can't be altered from a plain int, since you can't do a set not null. So, I am about to uninstall rhdb 2.1 and install postgres 7.3. Although, I suppose this is also known?

Whew! Life on the bleeding edge is a bit of a tempest. I was warned.

Comment 4 David Lawrence 2006-04-08 18:10:39 UTC
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.

Comment 5 David Lawrence 2008-09-16 16:49:51 UTC
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.

Comment 6 David Lawrence 2008-10-28 20:40:03 UTC
Unabled to replicate this issue in recent upgrade to Bugzilla 3.2.


Note You need to log in before you can comment on or make changes to this bug.