Bug 855503 - Wireless cannot be enabled if disabled in bios
Wireless cannot be enabled if disabled in bios
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-08 05:21 EDT by tim
Modified: 2013-07-31 19:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 19:37:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 586808 None None None 2012-09-08 05:21:48 EDT

  None (edit)
Description tim 2012-09-08 05:21:48 EDT
Description of problem:
Perhaps not so much a bug as a change request. Depends on how one would look at it. I see it a user friendlyness bug :)
This may also be related to bug 586808, which is about a laptop with wlan hardware switch (this eeePC 1000H doesn't have one, but it might be usefull to keep this feature for other hardware in mind)

After I disabled wireless from the networkmanager applet, the menu doesn't display the option to enable it anymore. A search on internet didn't give much results. I tried putting something like WIRELESS=yes or ENABLE_WIRELESS=yes in /etc/sysconfig/network, but that didn't make a difference. It wasn't until I just randomly tried the output of dmesg that I saw a hint. It said something about wlan being disabled in BIOS although the device was present. Next line said something along the lines of not using the device because it was probably inapropriate for this hardware.. This confuses me, as it seems that disabling wireless from the network manager applet changes this bios setting. Now I don't mind that this setting is changed in BIOS, as long as I'd be able to change it back or at least be *told* that is was changing my BIOS settings..

By the way: something much like this happens when enabling flight mode from gnome-control-center. Flight mode can not be disabled afterwards.. Although, please note that I use XFCE.

Version-Release number of selected component (if applicable):
0.9.4.0

How reproducible:
Always

Steps to Reproduce:
1. Make sure wireless is enabled in bios.
2. Disable wireless using the network manager applet.
3. Notice the option to enable wireless is gone.
4. Reboot, enable wireless in bios.
5. Notice the option to enable wireless is now back (though unchecked, which is fine to me)
6. Enable wireless using the networkmanager applet.
7. Open the gnome-control-center.
8. Go to network settings.
9. Enable flight mode.
10. Notice the option to disable flight mode is not there.
11. Reboot, enable wireless in bios.
  
Actual results:
Confusing functionality

Expected results:
Better integration between the parts involved so that the user gets more understandible behaviour.

Additional info:
I have not tested the reproducability on other environments than xfce.
Comment 1 Mads Kiilerich 2012-10-19 11:55:26 EDT
Bug 735516 seems similar. What you describe works fine with NM on other kinds of hardware. I guess the problem is problems with the hardware support in the kernel or other low level components.
Comment 2 Fedora End Of Life 2013-07-03 18:02:22 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 3 Fedora End Of Life 2013-07-31 19:37:59 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.