Bug 855510 - Alpha RC2: Cannot get past "Booting in ...... in 0 seconds" screen on iMac 2011 (booting from USB)
Alpha RC2: Cannot get past "Booting in ...... in 0 seconds" screen on iMac 20...
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
Depends On:
Blocks: F18Alpha-accepted/F18AlphaFreezeExcept
  Show dependency treegraph
Reported: 2012-09-08 07:03 EDT by Andreas Tunek
Modified: 2013-04-17 07:28 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-09-13 14:54:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Xorg.0.log (41.93 KB, text/x-log)
2013-04-17 07:28 EDT, Andreas Tunek
no flags Details

  None (edit)
Description Andreas Tunek 2012-09-08 07:03:36 EDT
Description of problem:
On a 2011 i5 iMac, if you boot TC5 Live image via USB you can get into the Grub2 menu, but it never goes past the "Booting Fedora 18 alpah tc5....in 0 seconds" screen.

Version-Release number of selected component (if applicable):

How reproducible:

Could be a kernel issue maybe...
Comment 1 Andreas Tunek 2012-09-08 07:06:49 EDT
Proposed NTH for alpha.
Comment 2 Adam Williamson 2012-09-10 13:28:06 EDT
Discussed at 2012-09-10 QA meeting, acting as an NTH review meeting. Agreed we need far more detail to evaluate this. What Mac model exactly (in the conventional MacMini,2,1 format)? Booted how (boot camp, 'native' EFI, what?) How was the USB stick written? Also, please re-test with TC6 or TC7/RC1 when it's released, as there have been improvements in the EFI boot stuff, and use the latest livecd-tools from updates-testing.
Comment 3 Andreas Tunek 2012-09-11 13:21:21 EDT
Tried RC2, did not even get the Grub splash, only command line. I just copied the files on a bootable USB stick, should that not be enough?

I think the machine is an iMac 2011, 2 (I do not really get the mac naming format).
Comment 4 Andreas Tunek 2012-09-11 14:25:06 EDT
Tried with liveusb-creator and livecd updates from updates testing. Still stuck on boot screen, booted nice on other machine.
Comment 5 Jóhann B. Guðmundsson 2012-09-12 14:39:08 EDT
What happens when you simply boot the imac with the rc2 livecd ?
Comment 6 Adam Williamson 2012-09-12 14:40:30 EDT
Discussed at 2012-09-12 NTH review meeting. We agreed there is still not enough data to evaluate this.

Andreas, we're still not sure you're using a 'correct' method for creating the USB stick. "I just copied the files on a bootable USB stick" doesn't sound like it was right. liveusb-creator is a proper tool, but we're not sure it actually works for UEFI boots at present.

The two methods we are sure should work for UEFI boots are:

dd if=filename.iso of=/dev/sdX
livecd-iso-to-disk --format --reset-mbr --efi filename.iso /dev/sdX1

you need to pass --efi when using litd; it doesn't make the stick EFI bootable by default.

Could you please try with one of those two methods and report back? Thanks.
Comment 7 Andreas Tunek 2012-09-13 14:54:20 EDT
livecd-iso-to-disk --format --reset-mbr --efi filename.iso /dev/sdb

with RC3 works!

Great job everyone!
Comment 8 Andreas Tunek 2013-04-17 07:28:47 EDT
Created attachment 736799 [details]

Note You need to log in before you can comment on or make changes to this bug.