This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 855514 - SELinux is preventing /usr/bin/nspluginviewer from 'write' accesses on the file index.theme.
SELinux is preventing /usr/bin/nspluginviewer from 'write' accesses on the fi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:dae1e1bd556d59ed438dcc0d5ad...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-08 08:19 EDT by Mircea Sava
Modified: 2012-09-10 02:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 02:25:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-08 08:19 EDT, Mircea Sava
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-08 08:19 EDT, Mircea Sava
no flags Details

  None (edit)
Description Mircea Sava 2012-09-08 08:19:04 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.5.3-1.fc17.i686

description:
:SELinux is preventing /usr/bin/nspluginviewer from 'write' accesses on the file index.theme.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that nspluginviewer should be allowed write access on the index.theme file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep nspluginviewer /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                unconfined_u:object_r:user_home_t:s0
:Target Objects                index.theme [ file ]
:Source                        nspluginviewer
:Source Path                   /usr/bin/nspluginviewer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           kde-baseapps-4.8.5-1.fc17.i686
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-146.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.5.3-1.fc17.i686 #1 SMP Wed Aug
:                              29 19:25:38 UTC 2012 i686 i686
:Alert Count                   1
:First Seen                    2012-09-08 15:11:06 EEST
:Last Seen                     2012-09-08 15:11:06 EEST
:Local ID                      4c33ca27-f858-4a35-a3fa-b40d21aa1cf9
:
:Raw Audit Messages
:type=AVC msg=audit(1347106266.645:39): avc:  denied  { write } for  pid=1379 comm="nspluginviewer" name="index.theme" dev="dm-3" ino=1593924 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1347106266.645:39): arch=i386 syscall=access success=no exit=EACCES a0=9290a60 a1=2 a2=41e1fa5c a3=2 items=0 ppid=1295 pid=1379 auid=17841 uid=17841 gid=17841 euid=17841 suid=17841 fsuid=17841 egid=17841 sgid=17841 fsgid=17841 tty=(none) ses=1 comm=nspluginviewer exe=/usr/bin/nspluginviewer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: nspluginviewer,mozilla_plugin_t,user_home_t,file,write
:
:audit2allow
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t user_home_t:file write;
:
:audit2allow -R
:
:#============= mozilla_plugin_t ==============
:allow mozilla_plugin_t user_home_t:file write;
:
Comment 1 Mircea Sava 2012-09-08 08:19:08 EDT
Created attachment 611005 [details]
File: type
Comment 2 Mircea Sava 2012-09-08 08:19:10 EDT
Created attachment 611006 [details]
File: hashmarkername
Comment 3 Miroslav Grepl 2012-09-10 02:25:21 EDT
It looks like your homedir is mislabeled. Could you try to execoute

# restorecon -R -v /home

If it does not help, please reopen the bug. Thank you.

Note You need to log in before you can comment on or make changes to this bug.