Bug 855518 - trac: please update to version 0.12.4
trac: please update to version 0.12.4
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: trac (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Felix Schwarz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-08 10:04 EDT by Jose Pedro Oliveira
Modified: 2013-01-17 17:37 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-24 12:07:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Trac 0.12.4 update - specfile changes (1.34 KB, patch)
2012-10-06 10:07 EDT, Jose Pedro Oliveira
no flags Details | Diff

  None (edit)
Description Jose Pedro Oliveira 2012-09-08 10:04:01 EDT
Description of problem:
Upstream has just released trac 0.12.4.

Version-Release number of selected component (if applicable):
trac-0.12.3-3.el6

Expected results:
To have trac version 0.12.4 available in EPEL6.

Additional info:

Download:
http://trac.edgewall.org/wiki/TracDownload
http://download.edgewall.org/trac/Trac-0.12.4.tar.gz

Closed tickets:
http://trac.edgewall.org/milestone/0.12.4
http://trac.edgewall.org/query?status=closed&group=resolution&milestone=0.12.4
Comment 1 Felix Schwarz 2012-09-08 16:01:01 EDT
Actually it's still a prerelease despite the "final" version number, see http://groups.google.com/group/trac-dev/msg/1f31a0b866e70fe9
Comment 2 Jose Pedro Oliveira 2012-10-06 10:07:54 EDT
Created attachment 622718 [details]
Trac 0.12.4 update - specfile changes
Comment 3 Felix Schwarz 2012-10-08 04:38:42 EDT
Jose, thank you very much for the patch. If you're interested, feel free to apply for Trac co-maintainership in EPEL.

I guess we need to update Trac in EPEL6 again in a few weeks as cboos plans to release 0.12.5 "soon" but let's
Comment 4 Felix Schwarz 2012-10-08 04:39:46 EDT
Jose, thank you very much for the patch. If you're interested, feel free to apply for Trac co-maintainership in EPEL.

I guess we need to update Trac in EPEL6 again in a few weeks as cboos plans to release 0.12.5 "soon" but as far as I can see the regression does not affect EL6 because it uses Python 2.6.
Comment 5 Fedora Update System 2012-10-08 04:46:04 EDT
trac-0.12.4-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trac-0.12.4-1.el6
Comment 6 Fedora Update System 2012-10-08 11:28:41 EDT
Package trac-0.12.4-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing trac-0.12.4-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-13102/trac-0.12.4-1.el6
then log in and leave karma (feedback).
Comment 7 Jose Pedro Oliveira 2012-10-24 12:07:41 EDT
Closing (already in EPEL6 stable repo).


Announcement:

 * Fedora EPEL 6 Update: trac-0.12.4-1.el6
   Mon Oct 22 20:55:32 UTC 2012
   https://lists.fedoraproject.org/pipermail/epel-package-announce/2012-October/008807.html
Comment 8 Jose Pedro Oliveira 2013-01-17 17:37:46 EST
(In reply to comment #4)
--[snip]--
> I guess we need to update Trac in EPEL6 again in a few weeks as cboos plans
> to release 0.12.5 "soon" but as far as I can see the regression does not
> affect EL6 because it uses Python 2.6.

... and Trac 0.12.5 was finally released:


Trac 0.12.5 (January 15, 2013)
http://svn.edgewall.org/repos/trac/tags/trac-0.12.5

Trac 0.12.5 is a maintenance release and contains
a few interesting fixes:
 - upload of .mht files (MHTML web page archive files) now works
   (#9880)
 - more robust parsing of attachment URLs (#10280) and uploaded
   file names (#10850)
 - lots of improvement to the date formatting code, which is now
   much more robust when timezone and daylight saving time
   computations are involved (#10768, #10863, #10864, #10912, #10920)
 - no longer generate invalid JSON encoded data with Python 2.4 and
   2.5 (#10877)
 - ... and a few more!

Note You need to log in before you can comment on or make changes to this bug.