Bug 855518 - trac: please update to version 0.12.4
Summary: trac: please update to version 0.12.4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: trac
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Schwarz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-08 14:04 UTC by Jose Pedro Oliveira
Modified: 2013-01-17 22:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-24 16:07:41 UTC


Attachments (Terms of Use)
Trac 0.12.4 update - specfile changes (1.34 KB, patch)
2012-10-06 14:07 UTC, Jose Pedro Oliveira
no flags Details | Diff

Description Jose Pedro Oliveira 2012-09-08 14:04:01 UTC
Description of problem:
Upstream has just released trac 0.12.4.

Version-Release number of selected component (if applicable):
trac-0.12.3-3.el6

Expected results:
To have trac version 0.12.4 available in EPEL6.

Additional info:

Download:
http://trac.edgewall.org/wiki/TracDownload
http://download.edgewall.org/trac/Trac-0.12.4.tar.gz

Closed tickets:
http://trac.edgewall.org/milestone/0.12.4
http://trac.edgewall.org/query?status=closed&group=resolution&milestone=0.12.4

Comment 1 Felix Schwarz 2012-09-08 20:01:01 UTC
Actually it's still a prerelease despite the "final" version number, see http://groups.google.com/group/trac-dev/msg/1f31a0b866e70fe9

Comment 2 Jose Pedro Oliveira 2012-10-06 14:07:54 UTC
Created attachment 622718 [details]
Trac 0.12.4 update - specfile changes

Comment 3 Felix Schwarz 2012-10-08 08:38:42 UTC
Jose, thank you very much for the patch. If you're interested, feel free to apply for Trac co-maintainership in EPEL.

I guess we need to update Trac in EPEL6 again in a few weeks as cboos plans to release 0.12.5 "soon" but let's

Comment 4 Felix Schwarz 2012-10-08 08:39:46 UTC
Jose, thank you very much for the patch. If you're interested, feel free to apply for Trac co-maintainership in EPEL.

I guess we need to update Trac in EPEL6 again in a few weeks as cboos plans to release 0.12.5 "soon" but as far as I can see the regression does not affect EL6 because it uses Python 2.6.

Comment 5 Fedora Update System 2012-10-08 08:46:04 UTC
trac-0.12.4-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/trac-0.12.4-1.el6

Comment 6 Fedora Update System 2012-10-08 15:28:41 UTC
Package trac-0.12.4-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing trac-0.12.4-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-13102/trac-0.12.4-1.el6
then log in and leave karma (feedback).

Comment 7 Jose Pedro Oliveira 2012-10-24 16:07:41 UTC
Closing (already in EPEL6 stable repo).


Announcement:

 * Fedora EPEL 6 Update: trac-0.12.4-1.el6
   Mon Oct 22 20:55:32 UTC 2012
   https://lists.fedoraproject.org/pipermail/epel-package-announce/2012-October/008807.html

Comment 8 Jose Pedro Oliveira 2013-01-17 22:37:46 UTC
(In reply to comment #4)
--[snip]--
> I guess we need to update Trac in EPEL6 again in a few weeks as cboos plans
> to release 0.12.5 "soon" but as far as I can see the regression does not
> affect EL6 because it uses Python 2.6.

... and Trac 0.12.5 was finally released:


Trac 0.12.5 (January 15, 2013)
http://svn.edgewall.org/repos/trac/tags/trac-0.12.5

Trac 0.12.5 is a maintenance release and contains
a few interesting fixes:
 - upload of .mht files (MHTML web page archive files) now works
   (#9880)
 - more robust parsing of attachment URLs (#10280) and uploaded
   file names (#10850)
 - lots of improvement to the date formatting code, which is now
   much more robust when timezone and daylight saving time
   computations are involved (#10768, #10863, #10864, #10912, #10920)
 - no longer generate invalid JSON encoded data with Python 2.4 and
   2.5 (#10877)
 - ... and a few more!


Note You need to log in before you can comment on or make changes to this bug.