Bug 855557 - F18 Live (alpha RC2) Text boot and geometry error instead of graphical
F18 Live (alpha RC2) Text boot and geometry error instead of graphical
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Sebastian Vahl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-08 18:16 EDT by Xavier Hourcade
Modified: 2012-09-13 20:23 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-13 20:23:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TC6 var-log folder, dmesg, free, ps aux and xsession-errors (61.93 KB, application/x-gzip)
2012-09-08 18:25 EDT, Xavier Hourcade
no flags Details

  None (edit)
Description Xavier Hourcade 2012-09-08 18:16:33 EDT
Description of problem:

  Fedora Live KDE boot in text mode with wrong resolution/geometry
  (then KDE does load fine, with good resolution, but v.high CPU)

Version-Release number of selected component (if applicable):

  Fedora KDE Live 18 alpha TC5 and TC6

How reproducible:

  Always

Steps to Reproduce:

  1. Boot Live media (USB stick here)
  
Actual results:

  Text mode at 640x480, unscaled, positioned at top left of 1440x900 display
  Then a few [OK] messages appear... on the same line as the progress bar,
    but in the top right area of display
  Then KDE session autoloads with correct resolution
    (but very high CPU usage while moving/refreshing windows, related ?).

Expected results:

  Graphic mode is loaded (plymouth charge theme ?)

Additional info:

  Asus V1S laptop with nVidia GeForce 8600M GT (hence nouveau)
  Graphical boot was fine here with F16 and F17, both KDE Live and install.
Comment 1 Xavier Hourcade 2012-09-08 18:25:37 EDT
Created attachment 611096 [details]
TC6 var-log folder, dmesg, free, ps aux and xsession-errors
Comment 2 Adam Williamson 2012-09-10 00:41:59 EDT
As an entirely cosmetic bug, -1 blocker, -1 nth.
Comment 3 Jaroslav Reznik 2012-09-10 04:13:26 EDT
It's probably some driver issue, we should track it but it's definitely not alpha blocker.
Comment 4 Xavier Hourcade 2012-09-10 06:18:51 EDT
Learning :) Might be related to #855560, will try to look closer at both
Comment 5 Xavier Hourcade 2012-09-12 10:46:56 EDT
Tested alpha RC2 Live ISOs, both KDE and Gnome, both default (nouveau) and vesa.
Looks like a driver issue indeed, and a duplicate of 855560, please advise
Comment 6 Xavier Hourcade 2012-09-12 22:55:32 EDT
And vesa provides expected results: text-based animation is up-scaled to full screen during boot, no geometry errors, small tty fonts.
Comment 7 Xavier Hourcade 2012-09-13 20:22:45 EDT
Fix released with F18 alpha RC3, plymouth charge is back on Live ISOs.

LXDE loads correctly, KDE runs into bug 848305, not tested other spins.

Note You need to log in before you can comment on or make changes to this bug.