Bug 855558 - [abrt] vim-enhanced-7.3.638-2.fc17: vm_exec: Process /usr/bin/vim was killed by signal 11 (SIGSEGV)
[abrt] vim-enhanced-7.3.638-2.fc17: vm_exec: Process /usr/bin/vim was killed ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
abrt_hash:245387354cce4665a8ea986b5b5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-08 18:19 EDT by Pascal Hartig
Modified: 2012-12-20 11:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:11:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.47 KB, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details
File: environ (2.88 KB, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details
File: backtrace (16.08 KB, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details
File: cgroup (129 bytes, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details
File: maps (9.53 KB, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details
File: dso_list (1.92 KB, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details
File: var_log_messages (478 bytes, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details
File: open_fds (371 bytes, text/plain)
2012-09-08 18:19 EDT, Pascal Hartig
no flags Details

  None (edit)
Description Pascal Hartig 2012-09-08 18:19:27 EDT
Description of problem:
Started vim without parameters with the custom configuration from github.com/passy/dotvim. Appears to be related to the ruby bindings.

Version-Release number of selected component:
vim-enhanced-7.3.638-2.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        vim
crash_function: vm_exec
kernel:         3.5.3-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #6 vm_exec at vm.c
: #7 rb_iseq_eval at vm.c
: #8 prelude_eval at prelude.c
: #9 Init_prelude at prelude.c
: #10 ruby_init_prelude at ruby.c
: #11 process_options at ruby.c
: #12 ruby_process_options at ruby.c
: #13 ensure_ruby_initialized at if_ruby.c
: #14 ex_ruby at if_ruby.c
: #15 do_one_cmd at ex_docmd.c
Comment 1 Pascal Hartig 2012-09-08 18:19:29 EDT
Created attachment 611085 [details]
File: core_backtrace
Comment 2 Pascal Hartig 2012-09-08 18:19:32 EDT
Created attachment 611087 [details]
File: environ
Comment 3 Pascal Hartig 2012-09-08 18:19:33 EDT
Created attachment 611089 [details]
File: limits
Comment 4 Pascal Hartig 2012-09-08 18:19:35 EDT
Created attachment 611090 [details]
File: backtrace
Comment 5 Pascal Hartig 2012-09-08 18:19:37 EDT
Created attachment 611091 [details]
File: cgroup
Comment 6 Pascal Hartig 2012-09-08 18:19:39 EDT
Created attachment 611092 [details]
File: maps
Comment 7 Pascal Hartig 2012-09-08 18:19:41 EDT
Created attachment 611093 [details]
File: dso_list
Comment 8 Pascal Hartig 2012-09-08 18:19:43 EDT
Created attachment 611094 [details]
File: var_log_messages
Comment 9 Pascal Hartig 2012-09-08 18:19:45 EDT
Created attachment 611095 [details]
File: open_fds
Comment 10 Holger Arnold 2012-10-15 04:26:26 EDT
When installing the package 'vim-command-t', the post-install fails due to a crash in vim.  I get the following error message:

  Non-fatal POSTIN scriptlet failure in rpm package vim-command-t-1.4-1.fc17.i686
  /var/tmp/rpm-tmp.Jr9GRs: line 1:  3002 Segmentation fault      (core dumped) vim -c ":helptags /usr/share/vim/vimfiles/doc" -c :q &>/dev/null
  warning: %post(vim-command-t-1.4-1.fc17.i686) scriptlet failed, exit status 139


backtrace_rating: 4
Package: vim-enhanced-7.3.638-2.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 Holger Arnold 2012-10-15 05:34:57 EDT
(In reply to comment #10)

> When installing the package 'vim-command-t', the post-install fails due to a
> crash in vim.

This problem goes away when ruby is installed.  Hence, the 'vim-command-t' package should require ruby.
Comment 12 Fedora Update System 2012-10-15 06:44:49 EDT
vim-7.3.682-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/vim-7.3.682-1.fc17
Comment 13 Fedora Update System 2012-10-15 19:30:16 EDT
Package vim-7.3.682-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vim-7.3.682-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16162/vim-7.3.682-1.fc17
then log in and leave karma (feedback).
Comment 14 Holger Arnold 2012-10-16 03:00:50 EDT
(In reply to comment #13, comment #10)

> Package vim-7.3.682-1.fc17:
> * should fix your issue,

Installing vim-command-t still fails with a segmentation fault in vim when ruby is not installed (installing this packages pulls in libyaml and ruby-libs but not ruby).

Should I open a new bug for this missing dependency?  (But even when a required binary is missing, the post-installation script should fail without crashing vim).
Comment 15 Fedora Update System 2012-12-20 11:11:57 EST
vim-7.3.682-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.