Bug 855608 - libgsf-1.14.24 is available
libgsf-1.14.24 is available
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libgsf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On: 770887
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 06:42 EDT by Julian Sikorski
Modified: 2012-11-22 21:56 EST (History)
1 user (show)

See Also:
Fixed In Version: libgsf-1.14.24.1-fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 05:00:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2012-09-09 06:42:42 EDT
Description of problem:
libgsf-1.14.22 is available. It is require for goffice, gnumeric and gnome-chemistry-utils updates to continue, so if possible, please push the update as far as Fedora 17.
Comment 1 Caolan McNamara 2012-09-10 04:35:07 EDT
1.14.24 you mean I suppose
Comment 2 Julian Sikorski 2012-09-10 05:43:20 EDT
Yes, I do mean 1.14.24, sorry. How far back  release-wise would you be willing to push this? Keep in mind that gnumeric will be  stuck at whatever is shipped now without a newer libgsf.
Comment 3 Caolan McNamara 2012-09-10 05:50:37 EDT
I can submit it as a update for f-18 with no sweat anyway. I'll do that now
Comment 4 Fedora Update System 2012-09-10 06:08:51 EDT
libgsf-1.14.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libgsf-1.14.24-1.fc18
Comment 5 Julian Sikorski 2012-09-10 12:31:13 EDT
Would f-17 be possible too?
I know that the decision to push gnumeric-1.11.x to what later became f-17 might have been a bit too optimistic, but:
- I am not getting reports of things breaking left and right
- gnumeric-1.12.0 was supposed to be out by f-17 release
- rolling back is never a pleasant thing to do
Comment 6 Caolan McNamara 2012-09-10 15:39:11 EDT
if it gets into F-18, then I can do an update for F-17
Comment 7 Julian Sikorski 2012-09-10 15:43:51 EDT
OK, awesome :)
Comment 8 Fedora Update System 2012-09-17 17:54:06 EDT
libgsf-1.14.24-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Julian Sikorski 2012-09-22 07:13:53 EDT
F-18 update is live since Monday, could you please prepare one for F-17 as promised?
Comment 10 Caolan McNamara 2012-09-24 09:55:41 EDT
unfortunately f-17 libgsf 1.14.21 contains some gnome-vfs2 stuff etc which is packaged as libgsf-gnome and 1.14.24 doesn't carry that stuff around anymore so its Obsoleted by the f-18 package and the remnants moved into the main package. So it'd likely be somewhat potentially disruptive as an update :-(
Comment 11 Julian Sikorski 2012-09-24 15:24:35 EDT
Maybe not so much disruptive, since raw-thumbnailer seems to be the only consumer:
$ sudo repoquery --source --whatrequires `repoquery --provides libgsf-gnome`
libgsf-1.14.21-3.fc17.src.rpm
libgsf-1.14.21-3.fc17.src.rpm
libgsf-1.14.21-3.fc17.src.rpm
raw-thumbnailer-0.99.1-8.fc17.src.rpm
libgsf-1.14.21-3.fc17.src.rpm
libgsf-1.14.21-3.fc17.src.rpm
libgsf-1.14.21-3.fc17.src.rpm
libgsf-1.14.21-3.fc17.src.rpm
raw-thumbnailer-0.99.1-8.fc17.src.rpm
libgsf-1.14.21-3.fc17.src.rpm
libgsf-1.14.21-3.fc17.src.rpm
raw-thumbnailer-0.99.1-8.fc17.src.rpm
Comment 12 Julian Sikorski 2012-09-30 14:04:10 EDT
I just looked at the raw-thumbnailer git, and it seems you have successfully built it against libgsf-1.14.24 for f18 and rawhide.
Are there any other packages which might be affected which repoquery has missed?
Comment 13 Julian Sikorski 2012-09-30 15:19:30 EDT
New raw-thumbnailer does not need libgsf at all.
Comment 14 Caolan McNamara 2012-10-01 11:52:43 EDT
re other packages. I don't know :-). The above looks promising, so I guess that if raw-thumbnailer is cleared (btw, is that really the intended dependency bug id ?) then its worth a shot pushing it into testing
Comment 15 Julian Sikorski 2012-10-29 16:04:58 EDT
raw-thumbnailer has been taken care of. Sorry it took so long, but the maintainer was non-responsive and I had to follow the orphaning process.
Comment 16 Fedora Update System 2012-11-13 09:55:58 EST
libgsf-1.14.24-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libgsf-1.14.24-1.fc17
Comment 17 Fedora Update System 2012-11-22 21:56:55 EST
libgsf-1.14.24-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.