Bug 855635 - engine [Quota]: when quota is enforced and we import a vm before we have a valid quota in the DC we continue in the import and fail with quota invalid error
engine [Quota]: when quota is enforced and we import a vm before we have a va...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Gilad Chaplik
Dafna Ron
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 09:24 EDT by Dafna Ron
Modified: 2016-02-10 15:14 EST (History)
9 users (show)

See Also:
Fixed In Version: si20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:59:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (378.52 KB, application/x-xz)
2012-09-09 09:24 EDT, Dafna Ron
no flags Details
screenshot (50.14 KB, image/jpeg)
2012-09-09 09:25 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-09-09 09:24:49 EDT
Created attachment 611235 [details]
log

Description of problem:

when we move our DC to quota enforce and try to import a vm before creating any quota in the setup we fail with quota is invalid error. 
since the quota roller is shown empty I think we should highlight the roller as empty and not allow the import. 

Version-Release number of selected component (if applicable):

si17

How reproducible:

100%

Steps to Reproduce:
1. move your DC to quota enforced
2. try to import a vm
3.
  
Actual results:

we continue with the import and fail on quota invalid CanDoAction

Expected results:

we should perform a check before we import (like we do for a valid domain) and if no quota exists we should highlight the roller for quota alerting user that the import will fail without a valid quota. 

Additional info: log
Comment 1 Dafna Ron 2012-09-09 09:25:18 EDT
Created attachment 611236 [details]
screenshot
Comment 2 Gilad Chaplik 2012-09-19 11:27:15 EDT
pushed upstream (http://gerrit.ovirt.org/8060)
Comment 6 Dafna Ron 2012-10-07 05:07:53 EDT
verified on si20

Note You need to log in before you can comment on or make changes to this bug.