This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 855644 - F18 Live (alpha RC2) Anaconda custom partition layout: no access to existing LVM/LUKS volumes
F18 Live (alpha RC2) Anaconda custom partition layout: no access to existing ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 10:22 EDT by Xavier Hourcade
Modified: 2012-10-22 14:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 14:26:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda.log, unlocking crypt prior to launch Anaconda, then again during execution (10.23 KB, text/x-log)
2012-09-12 13:31 EDT, Xavier Hourcade
no flags Details

  None (edit)
Description Xavier Hourcade 2012-09-09 10:22:59 EDT
Description of problem:

  Given a local disk with one partition, one LVM and one large LUKS containing another LVM : to install F18, I need to select as "/" mount point, one of the LVs located inside the LUKS.

  In custom partition setup screen, LUKS volume does appear, but it doesn't seem possible to unlock it from the UI. Clicking The white arrow to its right, brings no more information. Clicking the configure button at the bottom, produce no effects, except the above white arrow disappears.

Version-Release number of selected component (if applicable):

  F18 KDE Live alpha TC5

How reproducible:

  Always

Steps to Reproduce:

  1. Boot, launch Anaconda from Desktop, select language and accept fate
  2. Start custom partitioning
  
Actual results:

  LUKS volume is listed but unusable

Expected results:

  LUKS volume is listed, clicking it prompts for unlock passphrase.
  Then, LVM inside it is available hence its LVs can be selected as mount points

Additional info:

  LUKS and LVM are otherwise just fine on this system (reporting from F16 as installed within it, and I could successfully proceed with such installation, with the exact same conditions, using Anaconda from F17 KDE Live)

  ( and this is a blocker for me to test any F18 installation to hard disk from Live/Anaconda on this hardware )
Comment 1 Adam Williamson 2012-09-10 12:35:19 EDT
Discussed at 2012-09-10 QA meeting, acting as a blocker review meeting. We agreed that this issue qualifies as a blocker under current criteria, but the criterion is outdated and specifically tied to the old UI. It is currently undergoing revision. We will revisit this bug once the criterion has been revised.
Comment 2 Xavier Hourcade 2012-09-12 13:22:22 EDT
Tested F18 Live alpha RC2 ISOs. As previously :

* 2 volumes appear matching my LUKS/LVM size: one named "LUKS" and another named "Unknown", further down the volume list

* Hitting the "configure-like" icon, nothing happens with either of these two,
  besides the white arrow to disappear


New: I now tried unlocking the crypt manually, prior to launching Anaconda.

* `cryptsetup` unlocked it fine, confirmed by status command. Then in Anaconda, all was exactly as previously, including the right arrows / configure behavior, and LUKS contents were still not listed.

* I checked its status again from cli, and `cryptsetup status` said it was back to offline (?!). I unlocked it for the second time, confirmed by status, and could list its contents with lvm commands once again.

* From this point onwards in Anaconda, despite going "back" and trying again a few times, *none* of the existing volume on this local disk, did ever show up any more : only the Fedora 18 / new section at the top, was displayed.

Quitting Anaconda (thus causing reboot), I could confirm disk layout was untouched, still all good and functional.
Comment 3 Xavier Hourcade 2012-09-12 13:31:20 EDT
Created attachment 612187 [details]
anaconda.log, unlocking crypt prior to launch Anaconda, then again during execution

(from anaconda log, "Unknown" is the extended partition i.e. sda4 ?)
-
Comment 4 Adam Williamson 2012-09-12 13:45:55 EDT
Discussed at 2012-09-12 blocker review meeting. After further consideration we agreed this actually doesn't even hit the existing criterion, which is about *creating* encrypted/LUKS partitions, not re-using existing ones. It certainly doesn't hit any of the proposals currently under discussion for revising the criterion, all of which are looser than the current wording. Therefore, this is solidly rejected as a blocker.
Comment 5 Xavier Hourcade 2012-10-22 14:26:44 EDT
This appears to be fixed, tested Fedora-18-Beta-TC6-x86_64-Live-KDE.iso
Thanks!

Note You need to log in before you can comment on or make changes to this bug.