Bug 855652 - Calc becomes unresponsive with abnormal PID
Calc becomes unresponsive with abnormal PID
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
i686 Linux
unspecified Severity low
: ---
: ---
Assigned To: Eike Rathke
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 11:16 EDT by davidshumway
Modified: 2012-10-10 07:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 07:11:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description davidshumway 2012-09-09 11:16:59 EDT
Description of problem:
Using LibreOffice Calc. Pasted a small amount of data while all content was selected. Resulted in unresponsive behavior and very large PID number.

How can it be reproduced?
Not sure.

Version-Release number of selected component (if applicable):
3.5

How reproducible:
Not sure.

Steps to Reproduce:
1.
Had a quite large CSV file open - many, many rows, with about 10 columns.
Copied about 10 rows to the clipboard.
Created a new spreadsheet and pasted the 10 rows of content.
Cut to the clipboard the last column of the 10 rows of content.
Selected all the content (Control+A).
Pressed Control-V to paste clipboard content and erase highlighted content.
Pressed enter on dialog warning that all content would be overridden / erased.
Program and computer became quite unresponsive.
PID of LibreOffice was quite high.

This is `ps aux | grep office` after about 5-10 minutes of trying to get a Gnome Terminal running:
dave     29215  0.0  0.0  33304    84 ?        Sl   10:25   0:00 /opt/libreoffice3.5/program/oosplash --calc /home/dave/Downloads/FA2012.csv
dave     29233 18.8 73.0 3009664 2259992 ?     Sl   10:25   1:57 /opt/libreoffice3.5/program/soffice.bin --calc /home/dave/Downloads/FA2012.csv
root     29270  1.8  0.0   3540   308 ?        D    10:29   0:06 /usr/libexec/abrt-hook-ccpp 11 0 29233 500 500 1347200958 localhost.localdomain soffice.bin 636f726500
dave     29283  0.7  0.2 154220  8752 ?        Sl   10:33   0:01 gnome-terminal -x killall libreoffice

"FA2012.csv" is the very large CSV file. Normally the process IDs are below a few thousand. 
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2012-09-10 05:48:59 EDT
Can you attach the sample .csv. (but I'm guessing the problem is trying to effectively fill an infinitely sized selection)
Comment 2 Eike Rathke 2012-10-10 07:11:31 EDT
Ctrl+A and paste attempts to paste content repeatedly to all selected cells (i.e. which leads to memory exhaustion, depending on RAM and swap size that may take some time, but eventually the application will probably crash with out of memory, which apparently it did in your case given the abrt-hook-ccpp in ps output.

We can't do much about that other than upstream needed to implement special behavior for Ctrl+A selections to not operate with content/attribution adding commands.

Btw, there is no "abnormal PID" in your ps output, the actual PID depends on the number of processes run over time, 29233 is pretty normal.

Note You need to log in before you can comment on or make changes to this bug.