Bug 855660 - bash fail display properly when windows is resized
bash fail display properly when windows is resized
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 13:02 EDT by melanphos
Modified: 2014-01-12 19:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 09:10:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description melanphos 2012-09-09 13:02:44 EDT
Description of problem:
In some condition, bash dont display a new line while editing long commands

How reproducible:
Each time

Steps to Reproduce:
1. open a virtual terminal not maximized
2. start something like vi
3. maximize the virtual tty with alt + F10
4. quit vi
5. try write a very long command

Actual results:
bash display something like :

"end of commandend of prompt $ begin of the very long command"
Expected results:
"begin of prompt end of prompt $ begin of the very long command
end of command"

Fix:
The problem is fixed with setting the checkwinsize option. With should be done by default.
with 
shopt -s checkwinsize

the problem is better described here:
https://blogs.oracle.com/dp/entry/why_bash_doesn_t_work
Comment 1 Roman Rakus 2012-09-10 09:10:37 EDT
checkwinsize option is set on in /etc/bashrc. That file is part of setup package. And because it is set there, I'm closing this bug as not a bug.

Note You need to log in before you can comment on or make changes to this bug.