Bug 855699 - nfs not properly stopped on shutdown/reboot leading to unclean iscsi-hosted filesystems
nfs not properly stopped on shutdown/reboot leading to unclean iscsi-hosted f...
Status: CLOSED DUPLICATE of bug 856923
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
All Linux
unspecified Severity high
: rc
: ---
Assigned To: nfs-maint
Red Hat Kernel QE team
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 23:54 EDT by Chris Tracy
Modified: 2012-11-19 15:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 15:48:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to match NFS subsys name to init script (1.69 KB, patch)
2012-10-04 10:47 EDT, Mark
no flags Details | Diff

  None (edit)
Description Chris Tracy 2012-09-09 23:54:27 EDT
Description of problem:
Bug 717283 appears to be back in 6.3 with nfs-utils-1.2.3-26.  This results in any iSCSI hosted filesystems being uncleanly disconnected on shutdown/reboot, hence the high severity.

As before, the problem appears to be that /etc/rc.d/init/nfs creates the lockfile "/var/locks/subsys/nfsd" (note the trailing 'd') while /etc/rc.d/rc looks for the file "/var/locks/subsys/nfs" and thus doesn't think it needs to shut down nfs.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.3-26

How reproducible:
Always

Steps to Reproduce:
1. Mount filesystem via iSCSI
2. Export filesystem via NFS
3. Shutdown or reboot system
4. Filesystem does not cleanly unmount because NFS has it locked
  
Actual results:
NFS not properly stopped when shutting-down/rebooting

Expected results:
NFS should stop when rebooting, allowing iSCSI mounts to cleanly unmount.


Additional info:
Comment 2 Mark 2012-10-04 10:45:41 EDT
The implications of this bug are wider. The running nfsd prevents
clean unmounting of /var, regardless of whether this is exported.

Here's a patch with a fix.

In future, perhaps the script would be more appropriately named
'nfsd', to clarify that it is the NFS server.
Comment 3 Mark 2012-10-04 10:47:00 EDT
Created attachment 621690 [details]
Patch to match NFS subsys name to init script
Comment 4 Steve Dickson 2012-11-19 15:48:31 EST

*** This bug has been marked as a duplicate of bug 856923 ***

Note You need to log in before you can comment on or make changes to this bug.