Bug 855704 - mysql server prompts for password at startup
mysql server prompts for password at startup
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mysql (Show other bugs)
6.4
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Michal Schorm
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 00:33 EDT by John Newbigin
Modified: 2017-04-12 06:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-10 04:15:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Newbigin 2012-09-10 00:33:44 EDT
(This is for mysql-server but there is no Component for that in bugzilla)

Description of problem:
mysql server asks for a password at startup:

[root@mysql ~]# service mysqld start
Enter password: 
Starting MySQL:                                            [  OK  ]

How reproducible:
Every time


Steps to Reproduce:
1. Edit /etc/my.cnf and add
[client]
password

2. stop and start mysqld
  
Actual results:
The init script runs this command:
/usr/bin/mysqladmin --socket="$socketfile" --user=UNKNOWN_MYSQL_USER ping 

which prompts for a password.

Expected results:
The server should start without prompting for a password.

Additional info:
By adding 
--password=""
to the mysqladmin command, the prompt is not displayed.
Comment 1 Tom Lane 2012-09-10 00:51:13 EDT
Perhaps --no-defaults would be a more inclusive solution.
Comment 2 John Newbigin 2012-09-10 01:12:47 EDT
Indeed. I did not know about that option. In fact, I can't find any info about that option at all.

Still it does work :-)

(I was looking for a --no-password option but that does not exist).
Comment 3 Tom Lane 2012-09-29 18:06:02 EDT
I've pushed --no-defaults into the Fedora versions of the package.  It'll ultimately work its way into newer RHEL releases from there, but I'm not sure if this will get into RHEL5 without your filing a request with your customer support contact.
Comment 4 Honza Horak 2013-03-19 10:46:12 EDT
I am sorry, but it is now too late in the RHEL-5 release cycle. RHEL-5.10 (the next RHEL-5 minor release) is going to be the first production phase 2 [1] release of RHEL-5. Since phase 2 we'll be addressing only security and critical issues.
However, this one issue is not fixed in RHEL-6 yet therefore I am moving this bugzilla to RHEL-6.

Note You need to log in before you can comment on or make changes to this bug.