Bug 855716 - beaker-transfer stuck in while loop, when disabling cache with untransferred logs
beaker-transfer stuck in while loop, when disabling cache with untransferred ...
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.9
Unspecified Unspecified
low Severity unspecified (vote)
: 0.12
: ---
Assigned To: Dan Callaghan
Amit Saha
Misc
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 01:48 EDT by Raymond Mancy
Modified: 2014-12-07 20:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-11 00:56:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raymond Mancy 2012-09-10 01:48:06 EDT
If you set:

  CACHE = False

in labcontroller.conf when there are untransferred logs, then beaker-transfer gets stuck in a while loop.

This is because it returns True for transfer.transfer_logs() so does not enter sleep, and then transfer_recipe_logs() returns straightaway as CACHE is not enabled.
Comment 1 Dan Callaghan 2012-09-10 02:58:23 EDT
Maybe beaker-transfer should just bail out entirely if CACHE=False? It has no purpose otherwise.

Ideally it should exit non-zero before daemonising, then the administrator will see a big fat red "FAILED" if they try to start it when CACHE=False.
Comment 2 Nick Coghlan 2012-10-17 00:33:36 EDT
Bulk reassignment of issues as Bill has moved to another team.
Comment 3 Dan Callaghan 2013-02-25 00:50:00 EST
I wrote a patch for this while working on the harness API:

http://gerrit.beaker-project.org/1702
Comment 5 Amit Saha 2013-04-04 21:28:42 EDT
Due to the changes in log storage mechanism, the CACHE variable is defunct now. (See: http://beaker-project.org/docs-release-0.12/whats-new/release-0.12.html#logs-are-no-longer-sent-to-the-beaker-server)

The above patch adds the intelligence to beaker-transfer to bail out if ARCHIVE_SERVER is not configured. This is verified to be working as expected:

# service beaker-transfer start

Starting beaker-transfer: Archive server settings are missing from config file
                                                           [FAILED]
Comment 6 Dan Callaghan 2013-04-11 00:56:01 EDT
Beaker 0.12 has been released.

Note You need to log in before you can comment on or make changes to this bug.