Bug 855737 - libusbredirhost should not queue unlimited amounts of data, causing oom
libusbredirhost should not queue unlimited amounts of data, causing oom
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: usbredir (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Hans de Goede
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 03:09 EDT by Marko Myllynen
Modified: 2013-02-21 03:50 EST (History)
5 users (show)

See Also:
Fixed In Version: usbredir-0.5.1-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:50:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2012-09-10 03:09:36 EDT
Description of problem:
When redirecting a USB stick or a USB webcam with remote-viewer over a campus/site network between a laptop and a RHEV guest everything works as expected and the guest is able to use the redirected USB device without issues.

However, when redirecting a USB webcam over a slow network (e.g., VPN over 3G), remote-viewer rapidly starts to consume huge amounts of memory (several gigabytes if one doesn't close it) causing the local system to start swapping and grind to a halt unless the OOM killer gets it.

remote-viewer should not bring down / make unusable the user's system used to access RHEV guests even when sharing a USB device like webcam over a slow network.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-9
usbredir-0.4.3-1
Comment 1 Marko Myllynen 2012-09-10 03:10:19 EDT
This happens with both RHEL 6 / Windows 7 guests using Spice in Native mode.
Comment 3 Hans de Goede 2012-09-10 03:24:35 EDT
Thanks for the report:

1) First of all, what you're trying to do is never going to work. You simply cannot redirect a USB-2 webcam which generates up-to 240 Mbit / sec of video data over a slow network (e.g., VPN over 3G).

usbredir works at the USB level, so it does not know about video frames, so it cannot implement frame drop or something similar. To redirect a webcam you simply need at least as much bandwidth on the network as the webcam is using in USB bandwidth

2) With that said, the resulting behavior of course is not acceptable, what happens is that libusbredirhost is running the webcam at full-speed (the only speed available) and feeding video data to libusbredirparser as fast as it comes in. usbredirparser then puts this in its write queue, and since it is coming in faster then the write queue is getting emptied at the other end, the write queue grows boundlessly.

Fixing this should not be that hard, what it needs is a new libusbredirparser function to check how large the write queue is, and for libusbredirhost to drop isochronous data packets when the queue is too large (we cannot drop other packet types as the USB standard guarantees reliable delivery for all other packet types).
Comment 4 Hans de Goede 2012-09-19 07:42:36 EDT
This is fixed by the new usbredir-0.5.1 upstream release.
Comment 5 Hans de Goede 2012-09-21 03:37:15 EDT
This is fixed by usbredir-0.5.1-1.el6, moving to modified.
Comment 11 errata-xmlrpc 2013-02-21 03:50:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0346.html

Note You need to log in before you can comment on or make changes to this bug.