Bug 855762 - [RHSM GUI] 'All install products are covered by ...' dialog box should be actived in front of the SM main window.
[RHSM GUI] 'All install products are covered by ...' dialog box should be act...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: John Sefler
Entitlement Bugs
: Desktop, i18n
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-10 04:21 EDT by Lijun Li
Modified: 2013-01-07 23:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:03:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'All install products are covered by ...' dialog box should be actived in front of the SM main window. (123.28 KB, image/png)
2012-09-10 04:26 EDT, Lijun Li
no flags Details
The "All installed product are covered..." message dialog is now modal to the main Subscription Manager window. (159.17 KB, image/png)
2012-09-20 17:24 EDT, John Sefler
no flags Details

  None (edit)
Description Lijun Li 2012-09-10 04:21:34 EDT
Description of problem:
Now when I click the SM main window, it's to be hide in back of the SM main window, 'All install products are covered by ...' dialog box should be actived in front of the SM main window. 

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.14-1.el5.x86_64.rpm 


How reproducible:
100%

Steps to Reproduce:
1. Install os with latest RHEL5.9 Beta build
2. Run subscription-manager-gui.
3. Register the system using RHN account and password.
4. Subscribe to a subscription.
5. Click 'Auto-subscribe' on My Installed Products tab.


  
Actual results:
Now when I click the SM main window, it's to be hide in back of the SM main window, 'All install products are covered by ...' dialog box should be actived in front of the SM main window. 

Expected results:
'All install products are covered by ...' dialog box should be actived in front of the SM main window. 

Additional info:
Comment 1 Lijun Li 2012-09-10 04:26:14 EDT
Created attachment 611356 [details]
'All install products are covered by ...' dialog box should be actived in front of the SM main window.
Comment 2 RHEL Product and Program Management 2012-09-10 04:37:20 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Alex Wood 2012-09-14 16:28:38 EDT
There are three windows involved here: the main window A, the wizard window B, and the error dialog C.  In the buggy behavior, C is set_transient_for B but B is closed after C is displayed, leaving C orphaned and allowing A to be brought on top of C.  What we need to do is set C to be transient for A so that after B vanishes, C will stay on top.

See http://www.pygtk.org/docs/pygtk/class-gtkwindow.html#method-gtkwindow--set-transient-for
Comment 4 Alex Wood 2012-09-19 11:24:28 EDT
commit 1b409c7be5b0c478b32b6affb308e744a601abbe
Author: Alex Wood <awood@redhat.com>
Date:   Fri Sep 14 16:34:11 2012 -0400

    855762: Set correct parent for error dialog boxes raised by Autobind wizard.
    
    The error dialog boxes were being set transient for the wizard dialog
    which closes itself after raising the dialogs.  Consequently, the
    user was able to bring the main window into focus over the dialog
    rather than having the dialog always remain on top.

Available subscription-manager-1.0.19-1+
Comment 6 John Sefler 2012-09-20 17:24:52 EDT
Created attachment 615128 [details]
The "All installed product are covered..." message dialog is now modal to the main Subscription Manager window.

Verifying Version...
[root@rhsm-accept-rhel5 rhsm]# rpm -q subscription-manager-gui
subscription-manager-gui-1.0.19-1.el5

After clicking Auto-subscribe, a modal dialog opens that "searches for suitable service levels", once this dialog closes, the message dialog that says "All installed product are covered..." opens.  It too is modal and can no longer be hidden behind the main Subscription Manager gui.

Moving to VERIFIED.
Comment 8 errata-xmlrpc 2013-01-07 23:03:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.