Bug 855825 - Can't connect to mongdb any more after move app with mongodb embed accross district
Can't connect to mongdb any more after move app with mongodb embed accross di...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 06:26 EDT by Rony Gong
Modified: 2015-05-14 22:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-17 17:29:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
development.log (13.07 KB, text/plain)
2012-09-10 06:26 EDT, Rony Gong
no flags Details

  None (edit)
Description Rony Gong 2012-09-10 06:26:53 EDT
Created attachment 611389 [details]
development.log

Description of problem:
After move, I found the mongodb process isn't up, so conentc connect success.
I found only ruby, perl, nodejs  could work well, all other app embemd with mongodb can't work well after move.


Version-Release number of selected component (if applicable):
devenv_2140


How reproducible:
always


Steps to Reproduce:
1.Create multile node env, create 2 districts and add node to them.
2.Create non_scalable app like(python,jboss, php),embemd mongodb
3.Them move this app accross district
rhc-admin-move --gear_uuid 7078fe275f7d4fea936c766b3bb21982 -i ip-10-122-75-125 --allow_change_district

  
Actual results:
ssh into this app
[q2php-qgong.dev.rhcloud.com ~]\> mongo
MongoDB shell version: 2.0.2
connecting to: 127.1.251.1:27017/admin
Mon Sep 10 06:07:44 Error: couldn't connect to server 127.1.251.1:27017 shell/mongo.js:86
exception: connect failed



Expected results:
could connect mongodb success.


Additional info:
all other db like mysql and postgresql work well.
Comment 1 Rony Gong 2012-09-10 06:29:07 EDT
For scalabe app embed with mongodb, after move, check mongodb connection.
[qsphp-qgong.dev.rhcloud.com ~]\> mongo
MongoDB shell version: 2.0.2
connecting to: b13281fa37-qgong.dev.rhcloud.com:38036/admin
Mon Sep 10 06:28:10 DBClientCursor::init call() failed
Mon Sep 10 06:28:10 Error: Error during mongo startup. :: caused by :: DBClientBase::findN: transport error: b13281fa37-qgong.dev.rhcloud.com:38036 query: { whatsmyuri: 1 } shell/mongo.js:86
exception: connect failed
Comment 2 John Poelstra 2012-09-11 13:08:04 EDT
rajat looking at and expect to fix today
Comment 3 Rajat Chopra 2012-09-11 16:13:12 EDT
Order issue, if mongodb is called first on move, and framework later, it causes trouble. Fixed with rev#a8e3e5c2bd15f8ba1a6954e82726d915fecb4aaf in crankcase.repo!
Pull request in queue.
Comment 4 Xiaoli Tian 2012-09-12 05:34:22 EDT
(In reply to comment #3)
> Order issue, if mongodb is called first on move, and framework later, it
> causes trouble. Fixed with rev#a8e3e5c2bd15f8ba1a6954e82726d915fecb4aaf in
> crankcase.repo!
> Pull request in queue.

https://github.com/openshift/crankcase/pull/472 is merged in devenv_2158
Above commit is in master, move it to ON_QA to verify.
Comment 5 Chandrika Gole 2012-09-12 22:51:28 EDT
verified

Note You need to log in before you can comment on or make changes to this bug.