Bug 855850 - Auto-heal for expired certs is not working
Auto-heal for expired certs is not working
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adrian Likins
Entitlement Bugs
:
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-09-10 07:57 EDT by Shwetha Kallesh
Modified: 2012-10-25 12:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 12:39:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shwetha Kallesh 2012-09-10 07:57:26 EDT
Description of problem:
Auto-heal for expired certs is not working

Version-Release number of selected component (if applicable):
[root@unused ~]# subscription-manager version
subscription-manager: 1.0.17-1.el5
python-rhsm: 1.0.7-1.el5


How reproducible:


Steps to Reproduce:
1.Auto-subscribe 
2.[root@unused ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Stackable with Awesome OS for x86_64 Bits
Product ID:           	1000000000000023
Version:              	3.11
Arch:                 	x86_64
Status:               	Subscribed
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Developer Basic
Product ID:           	1144
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:   
              	
3.[root@unused ~]# date
Mon Sep 10 17:07:35 IST 2012
[root@unused ~]# date 091017082013
Tue Sep 10 17:08:00 IST 2013
[root@unused ~]# service rhsmcertd restart
Stopping rhsmcertd...                                      [  OK  ]
Starting rhsmcertd...                                      [  OK  ]
[root@unused ~]# date
Tue Sep 10 17:08:19 IST 2013
[root@unused ~]# cat /etc/rhsm/rhsm.conf | grep heal
# Frequency of autoheal check (1440 min = 1 day):
healFrequency = 2

[root@unused ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Stackable with Awesome OS for x86_64 Bits
Product ID:           	1000000000000023
Version:              	3.11
Arch:                 	x86_64
Status:               	Expired
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Developer Basic
Product ID:           	1144
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

[root@unused ~]# date
Mon Sep 10 17:10:35 IST 2013

[root@unused ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Stackable with Awesome OS for x86_64 Bits
Product ID:           	1000000000000023
Version:              	3.11
Arch:                 	x86_64
Status:               	Expired
Starts:               	
Ends:                 	

Product Name:         	Awesome OS Developer Basic
Product ID:           	1144
Version:              	1.0
Arch:                 	ALL
Status:               	Not Subscribed
Starts:               	
Ends:                 	

  
Actual results:


Expected results:


Additional info:
Comment 1 Adrian Likins 2012-09-20 15:55:27 EDT
This looks like the correct behaviour to me. 

list --installed is showing the product as expired. 

What was the expected behaviour?
Comment 2 Adrian Likins 2012-09-20 15:59:49 EDT
Ah, it's not healing.
Comment 3 Shwetha Kallesh 2012-09-21 07:19:46 EDT
Its working now..

[root@localhost pki]# rpm -qa | grep subscription-manager
subscription-manager-migration-1.0.19-1.el5
subscription-manager-migration-data-1.11.2.4-1.el5
subscription-manager-debuginfo-1.0.19-1.el5
subscription-manager-gui-1.0.19-1.el5
subscription-manager-1.0.19-1.el5
subscription-manager-firstboot-1.0.19-1.el5


[root@localhost pki]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Awesome OS for S390 Bits
Product ID:           	100000000000060
Version:              	3.11
Arch:                 	s390
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Stackable with Awesome OS for x86_64 Bits
Product ID:           	1000000000000023
Version:              	3.11
Arch:                 	x86_64
Status:               	Expired
Starts:               	
Ends:                 	

[root@localhost pki]# service rhsmcertd restart
Stopping rhsmcertd...                                      [  OK  ]
Starting rhsmcertd...                                      [  OK  ]


[root@localhost pki]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Awesome OS for S390 Bits
Product ID:           	100000000000060
Version:              	3.11
Arch:                 	s390
Status:               	Not Subscribed
Starts:               	
Ends:                 	

Product Name:         	Stackable with Awesome OS for x86_64 Bits
Product ID:           	1000000000000023
Version:              	3.11
Arch:                 	x86_64
Status:               	Subscribed
Starts:               	
Ends:
Comment 4 Adrian Likins 2012-10-05 11:06:54 EDT
If this is working now, moving back to modified.

Note You need to log in before you can comment on or make changes to this bug.