Bug 855875 - /usr/sbin/grub2-probe --target=hints_string : No such file or directory
/usr/sbin/grub2-probe --target=hints_string : No such file or directory
Status: CLOSED DUPLICATE of bug 826833
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 09:40 EDT by Derrien
Modified: 2012-09-10 10:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-10 10:09:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derrien 2012-09-10 09:40:21 EDT
Description of problem:

grub2-mkconfig -o /boot/grub2/grub.cfg doesn't create /boot/grub2/grub.cfg so we are getting the GRUB 2 boot prompt...

The issue seems /usr/sbin/grub2-probe :

[root@bluesy (Fedora 17) grub2]$ /usr/sbin/grub2-probe --device /dev/sdc1 --target=hints_string
/usr/sbin/grub2-probe: error: cannot open `/sys/devices/pci0000:00/0000:00:01.0/0000:02:00.0/host4/port-4:0/end_device-4:0/sas_device:end_device-4:0/phy_identifier': No such file or directory.

There is no '/sys/devices/pci0000:00/0000:00:01.0/0000:02:00.0/host4/port-4:0/end_device-4:0/sas_device:end_device-4:0/phy_identifier' but there is '
/sys/devices/pci0000:00/0000:00:01.0/0000:02:00.0/host4/port-4:0/end_device-4:0/sas_device/end_device-4:0/phy_identifier'

(end_device-4:0/sas_device instead of sas_device:end_device-4:0 )

[root@bluesy (Fedora 17) ~]$ ls -l /sys/devices/pci0000:00/0000:00:01.0/0000:02:00.0/host4/port-4:0/end_device-4:0/sas_device/end_device-4:0/phy_identifier
-r--r--r-- 1 root root 4096 Sep  7 19:04 /sys/devices/pci0000:00/0000:00:01.0/0000:02:00.0/


Version-Release number of selected component (if applicable):
grub2-2.0-0.25.beta4.fc17.x86_64


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Derrien 2012-09-10 09:53:55 EDT
Missing a piece...

[root@bluesy (Fedora 17) anaconda]$ ls -l /sys/devices/pci0000:00/0000:00:01.0/0000:02:00.0/host4/port-4:0/end_device-4:0/sas_device/end_device-4:0/phy_identifier
-r--r--r-- 1 root root 4096 Sep  7 19:04 /sys/devices/pci0000:00/0000:00:01.0/0000:02:00.0/host4/port-4:0/end_device-4:0/sas_device/end_device-4:0/phy_identifier
Comment 2 Mads Kiilerich 2012-09-10 10:09:31 EDT

*** This bug has been marked as a duplicate of bug 826833 ***

Note You need to log in before you can comment on or make changes to this bug.