Bug 855884 - Virtualization Guests - NumberFormatException
Virtualization Guests - NumberFormatException
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
550
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Martin Minar
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2012-09-10 10:11 EDT by Martin Korbel
Modified: 2016-07-03 20:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Korbel 2012-09-10 10:11:01 EDT
Description of problem:
I select a virtual guest on virtual host on the page /rhn/systems/details/virtualization/VirtualGuestsList.do.  Leave edit field "allocation to equal" empty and click Apply Changes. I get Internal Server Error and NumberFormatException in catalina.out.


Version-Release number of selected component (if applicable):
Sat 5.5.0
Sat 5.4.1

How reproducible:
100%

Steps to Reproduce:
1. We have got client server (virtual host) with same virtual guests.
2. Virtual host has got Virtualization Entitlement enabled.
3. Systems -> <virtual-host> -> Virtualization (/rhn/systems/details/virtualization/VirtualGuestsList.do)
4. Check same virtual guests
 4.1 Leave edit field "allocation to equal" empty
 4.2 click "Apply Changes"

  
Actual results:
 Internal Server Error
 NumberFormatException in catalina.out (see attachment).

Expected results:
 Same as I fill non-number (letters) value into "allocation to equal". 

Additional info:
Comment 1 Tomas Lestach 2012-09-12 11:40:39 EDT
fixing NumberFormatException and couple of issues with information messages ...

spacewalk.git: e61536a7202e5e66b252e4aa8ed629cd2f326b5d
Comment 4 Clifford Perry 2013-10-01 17:54:01 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.