Bug 855889 - libselinux should support per-user login contexts
libselinux should support per-user login contexts
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.4
All Linux
high Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 766000
  Show dependency treegraph
 
Reported: 2012-09-10 10:25 EDT by Jakub Hrozek
Modified: 2013-02-21 03:29 EST (History)
4 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-166.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:29:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jakub Hrozek 2012-09-10 10:25:22 EDT
Description of problem:
In order to support the central management of SELinux limits, the libselinux library in RHEL6.4 must support setting the context based on the contents of /etc/selinux/targeted/logins/$username

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. put a valid context into /etc/selinux/targeted/logins/$username
2. log in as $username
3. id -Z
  
Actual results:
unconfined_u

Expected results:
the context in the /etc/selinux/targeted/logins/$username file

Additional info:
This is a dependency of https://bugzilla.redhat.com/show_bug.cgi?id=766000
Comment 1 RHEL Product and Program Management 2012-09-10 10:38:15 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 11 errata-xmlrpc 2013-02-21 03:29:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0314.html

Note You need to log in before you can comment on or make changes to this bug.