Bug 855894 - cron daemon does not ignore rpmnew/rpmsave files
cron daemon does not ignore rpmnew/rpmsave files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 10:42 EDT by Paul Wouters
Modified: 2013-01-02 09:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 09:32:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2012-09-10 10:42:48 EDT
Description of problem:

when someone changes a cron job shipped in a package in /etc/cron*, and an update happens, there is now either an rpmsave or rpmnew file in addition to the cron file itself, resulting in TWO files executing almost identical content at likely the identical time - causing various problems

Is it possible to ensure rpmsave/rpmnew files are never actually executed by cron
Comment 1 Marcela Mašláňová 2012-11-22 07:30:19 EST
Are you sure? I created job.rpmnew file and it wasn't executed.

There is cron option permit all jobs. Don't you have in config option -p?
cat /etc/sysconfig/crond

I can't reproduce it, so please give me better reproducer.

Note You need to log in before you can comment on or make changes to this bug.