Bug 855919 - Firefox freezes on Fedora 18 for PPC64
Firefox freezes on Fedora 18 for PPC64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
18
ppc64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Reopened
Depends On: 813095 824463
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 11:35 EDT by Gustavo Luiz Duarte
Modified: 2012-10-31 07:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 813095
Environment:
Last Closed: 2012-10-31 07:55:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Do not decommit memory on PPC (553 bytes, patch)
2012-09-10 12:08 EDT, Gustavo Luiz Duarte
no flags Details | Diff

  None (edit)
Description Gustavo Luiz Duarte 2012-09-10 11:35:04 EDT
Description of problem:
Firefox freezes after a few minutes of usage.
Firefox seems to be stuck, there is a LOT of messages in the strace like this:
madvise(0xfff574ce000, 4096, MADV_DONTNEED) = -1 EINVAL (Invalid argument)


Version-Release number of selected component (if applicable):
firefox-15.0-2.fc18.ppc64
xulrunner-15.0-2.fc18.ppc64


How reproducible:
A few minutes browsing random pages has been enough to reproduce the issue.

Steps to Reproduce:
1. Create a mock env for Fedora 18 for PPC64
2. Install Firefox
3. Run firefox
4. Browse a few random pages
  
Actual results:
Firefox freezes (UI stops responding and/or updating)


Expected results:
Firefox UI should continue working.
Comment 1 Gustavo Luiz Duarte 2012-09-10 12:08:14 EDT
Created attachment 611481 [details]
Do not decommit memory on PPC

Do not decommit memory on PPC since decommit logic assumes PageSize == ArenaSize. On PPC we have 64K page size, which is not feasible for ArenaSize. Rework of Martin's patch from https://bugzilla.mozilla.org/show_bug.cgi?id=746112

Please apply this patch to xulrunner code. This patch should fix the Firefox freezes.
Comment 2 Martin Stransky 2012-10-31 07:55:35 EDT
Uploaded to git.

Note You need to log in before you can comment on or make changes to this bug.