Bug 855936 - [Backend][Storage][Direct LUN] NPE when deleting direct (lun at org.ovirt.engine.core.bll.ImagesHandler.removeLunDisk(ImagesHandler.java:664))
[Backend][Storage][Direct LUN] NPE when deleting direct (lun at org.ovirt.eng...
Status: CLOSED DUPLICATE of bug 854141
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.1.0
Assigned To: Liron Aravot
storage
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 12:41 EDT by Jakub Libosvar
Modified: 2016-02-10 14:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 04:14:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (2.77 KB, application/x-gzip)
2012-09-10 12:41 EDT, Jakub Libosvar
no flags Details

  None (edit)
Description Jakub Libosvar 2012-09-10 12:41:09 EDT
Created attachment 611493 [details]
logs

Description of problem:
When trying to remove direct lun NPE occurs:
2012-09-10 18:30:36,996 ERROR [org.ovirt.engine.core.bll.RemoveDiskCommand] (pool-4-thread-50) [60ed727a] Command org.ovirt.engine.core.bll.RemoveDiskCommand throw exception: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.ImagesHandler.removeLunDisk(ImagesHandler.java:664) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.RemoveDiskCommand$1.runInTransaction(RemoveDiskCommand.java:295) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.RemoveDiskCommand$1.runInTransaction(RemoveDiskCommand.java:292) [engine-bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInNewTransaction(TransactionSupport.java:204) [engine-utils.jar:]
        at org.ovirt.engine.core.bll.RemoveDiskCommand.removeLunDisk(RemoveDiskCommand.java:292) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.RemoveDiskCommand.executeCommand(RemoveDiskCommand.java:287) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.ExecuteWithoutTransaction(CommandBase.java:819) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:910) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1269) [engine-bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:168) [engine-utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:107) [engine-utils.jar:]
        at org.ovirt.engine.core.bll.CommandBase.Execute(CommandBase.java:925) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.ExecuteAction(CommandBase.java:275) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.executeValidatedCommands(MultipleActionsRunner.java:182) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner.RunCommands(MultipleActionsRunner.java:162) [engine-bll.jar:]
        at org.ovirt.engine.core.bll.MultipleActionsRunner$1.run(MultipleActionsRunner.java:84) [engine-bll.jar:]
        at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:64) [engine-utils.jar:]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471) [rt.jar:1.7.0_05-icedtea]
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334) [rt.jar:1.7.0_05-icedtea]
        at java.util.concurrent.FutureTask.run(FutureTask.java:166) [rt.jar:1.7.0_05-icedtea]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_05-icedtea]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_05-icedtea]
        at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_05-icedtea]


Version-Release number of selected component (if applicable):
rhevm-backend-3.1.0-15.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Have direct LUN in rhevm
2. Try to remove it
3.
  

Additional info:
Logs attached
Blocks direct lun sanity tests
Comment 2 Allon Mureinik 2012-09-11 09:55:25 EDT
Liron - AFAIK, this is something you solved (FC related, IIRC) - please confirm?
Comment 3 Liron Aravot 2012-09-12 04:14:15 EDT

*** This bug has been marked as a duplicate of bug 854141 ***

Note You need to log in before you can comment on or make changes to this bug.