Bug 855946 - mount.cifs does not recognize/implement the nofail option
mount.cifs does not recognize/implement the nofail option
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cifs-utils (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 13:17 EDT by Peter Trenholme
Modified: 2014-06-18 03:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:24:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2012-09-10 13:17:12 EDT
Description of problem:
An attempt to use a CIFS entry in the fstab having a "nofail" option produces an "unrecognized option" message, and, if the mount fails, a failure message is generated. (On a local network, failure can be expected if the target system is turned off.)

Version-Release number of selected component (if applicable):
5.6

How reproducible:
Every time

Steps to Reproduce:
1. Add a line in /etc/fstab for a cifs share with the "nofail" option specified.
2. Try to mount the share
3.
  
Actual results:
mount error(22): Invalid argument

Expected results:
Share mounted if available.

Additional info:
The bug is relatively minor since a "noauto" can be used, but it should be trivial to implement a "nofail."

The "nofail" option is listed as a "filesystem independent mount option" of the mount command, so it should be supported. (Output to stderr might be appropriate, but no error code should be reported,)

Note that, if the "noauto" is used, the share(s) need to be mounted after the boot completes.
Comment 1 Jeff Layton 2012-10-08 06:48:49 EDT
Ok, patch sent to mailing list that seems to do the right thing:

    http://article.gmane.org/gmane.linux.kernel.cifs/7097

...if you could also test it, that would be helpful. I'll plan to commit it in a few days if no one objects.
Comment 2 Fedora Update System 2012-10-09 21:22:55 EDT
cifs-utils-5.7-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/cifs-utils-5.7-1.fc17
Comment 3 Fedora Update System 2012-10-10 20:55:20 EDT
Package cifs-utils-5.7-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cifs-utils-5.7-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15827/cifs-utils-5.7-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-12-20 11:25:00 EST
cifs-utils-5.7-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.