Bug 855991 - jack needs rebuild for removal of libfreebob
jack needs rebuild for removal of libfreebob
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: jack-audio-connection-kit (Show other bugs)
18
All All
unspecified Severity urgent
: ---
: ---
Assigned To: Orcan Ogetbil
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Alpha-accepted/F18AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-10 17:16 EDT by Adam Williamson
Modified: 2012-09-18 08:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-18 08:59:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-09-10 17:16:40 EDT
libfreebob's removal from f18 means jack needs to be rebuilt. The rebuild is already done:

https://admin.fedoraproject.org/updates/FEDORA-2012-13308/jack-audio-connection-kit-1.9.8-11.fc18

but I'm filing this bug so we can nominate it as NTH, and pull the build into the Alpha. the LXDE and SoaS spins include jack, and fail to compose if it can't be installed.
Comment 1 Adam Williamson 2012-09-12 14:42:13 EDT
Discussed at 2012-09-12 NTH review meeting. Accepted as NTH as a violation of "There must be no file conflicts (cases where the files in some packages conflict but the packages have explicit Conflicts: tags are acceptable) or unresolved package dependencies during a media-based (DVD) install" for a non-blocking spin. (This might actually be a blocker, as a DVD composed with the bad jack might have unresolved deps, but it's not important, we have the fix anyhow.) Note that the fix was included in RC2 already, as it was clear this would be accepted.
Comment 2 Adam Williamson 2012-09-12 16:19:32 EDT
RC2 has an LXDE spin, so this is clearly VERIFIED.
Comment 3 Orcan Ogetbil 2012-09-12 22:16:07 EDT
Sorry for the trouble Adam, I would have waited to drop libfreebob from the distro if I knew it was going to cause problems with the Alpha compose. I am glad that things are resolved now. Jack will have another update in a couple weeks, due to libffado update, probably the last update before Gold. But I don't think we will have such an issue with that update in particular.
Comment 4 Adam Williamson 2012-09-17 20:36:17 EDT
no problem, I quite like it when I get to do package builds. it's restful. :P
Comment 5 Kamil Páral 2012-09-18 08:59:08 EDT
The update has been pushed to stable, closing.

Note You need to log in before you can comment on or make changes to this bug.