Bug 856005 - [RFE]log collector default option should be "collect" and not "list
[RFE]log collector default option should be "collect" and not "list
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector (Show other bugs)
3.1.0
All Linux
urgent Severity low
: ---
: 3.1.0
Assigned To: Keith Robertson
Ilanit Stein
integration
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 18:30 EDT by Marina
Modified: 2016-07-03 21:34 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marina 2012-09-10 18:30:56 EDT
Today default log collector's default option is list and not collect, which somehow contradicts with the tool name, that hints it is supposed to collect logs.
Customers run rhevm-log-collector without providing any parameters and nothing happens. So they think log collector does not work and they provide GSS sos-report instead, which is insufficient.

Additional:
If the idea behind this design was to prevent collecting information from all the host on the system, the tool should ask the user whether he is interested in collecting info from all the hosts, since it can be long operation.

This happens at least to 50% of the customers.
And to 100% of users running this command first time.
Having this tool running "collect" by default would significantly decrease initial interaction with customers.
Comment 1 Keith Robertson 2012-09-18 22:37:35 EDT
http://gerrit.ovirt.org/8040
Comment 5 Ilanit Stein 2012-10-18 07:36:36 EDT
Verified on SI20

Note You need to log in before you can comment on or make changes to this bug.