Bug 856016 - Please include vm-sound-pulse
Please include vm-sound-pulse
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: squeak-vm (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Škarvada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 21:17 EDT by Matthew Miller
Modified: 2012-11-26 23:43 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-26 23:43:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2012-09-10 21:17:46 EDT
Audio doesn't work in Scratch (which we are working on packaging).

According to Lennart Poettering, ALSA is a non-starter, and we need a working PulseAudio plugin. (See: bugs.squeak.org/view.php?id=7328)


Such a plugin exists in newer releases of Squeak VM; according to http://www.squeakvm.org/unix/, added in 3.11.3.2135 release, and updated in  	4.0.3.2202.

Looks like our version is rather out of date; I'm not sure if there's a good reason to hold at the old release or not. If so, could we maybe at least backport the plugin?
Comment 1 Ismael Olea 2012-09-13 05:03:22 EDT
Maybe you could propose an updated spec that could be tested against etoys and other, if any, current app.
Comment 2 Matthew Miller 2012-09-13 09:56:52 EDT
I looked at it briefly. There a lot of changes going to the cmake-based build process, and a number of things upstream seems to do badly (assumptions about /usr/lib even on 64-bit), so I think it would be done _best_ by someone with existing knowledge of the project. But if no one steps up by F19-feature timeframe, I will look at what I can do.
Comment 3 Matthew Miller 2012-09-29 11:23:50 EDT
See also bug #861633 -- request for updated squeak-vm.
Comment 4 Fedora Admin XMLRPC Client 2012-10-22 16:29:37 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Jaroslav Škarvada 2012-11-23 08:45:00 EST
I am moving this to f18. It will be resolved by rebase, see bug 861633. In case you need this fixed in f17, please let me know.
Comment 6 Fedora Update System 2012-11-23 10:06:04 EST
squeak-image-4.3-1.fc18,squeak-vm-4.10.2.2614-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/squeak-image-4.3-1.fc18,squeak-vm-4.10.2.2614-1.fc18
Comment 7 Fedora Update System 2012-11-23 14:54:38 EST
Package squeak-image-4.3-1.fc18, squeak-vm-4.10.2.2614-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing squeak-image-4.3-1.fc18 squeak-vm-4.10.2.2614-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18919/squeak-image-4.3-1.fc18,squeak-vm-4.10.2.2614-2.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-11-26 23:43:47 EST
squeak-image-4.3-1.fc18, squeak-vm-4.10.2.2614-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.