Bug 856036 - Lots of packages missing from DVD compose since major comps rework (Alpha RC1)
Lots of packages missing from DVD compose since major comps rework (Alpha RC1)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
18
All All
unspecified Severity high
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-10 22:53 EDT by Adam Williamson
Modified: 2014-03-16 23:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 13:19:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
package diff from tc5 to rc1 (67.37 KB, text/plain)
2012-09-10 22:55 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-09-10 22:53:33 EDT
The big comps/spin-kickstarts rework landed between F18 Alpha TC5 and TC6. Lots of packages went missing. We thought we'd nailed the problem for RC1, but it seems...not. Still lots of packages missing between TC5 and RC1. The diff is attached.

This is an obvious release blocker, it hits several criteria. gnome-shell, firewalld, evolution and firefox are all missing from the DVD, among many others. Criteria...let's say:

"Following on from the previous criterion, after firstboot is completed and on subsequent boots, a system installed according to any of the above criteria (or the appropriate Beta or Final criteria, when applying this criterion to those releases) must boot to a working graphical environment without unintended user intervention. This includes correctly accessing any encrypted partitions when the correct passphrase is supplied"

and:

"It must be possible to run the default web browser and a terminal application from all release-blocking desktop environments. The web browser must be able to download files, load extensions, and log into FAS"

Should be enough to be going along with.
Comment 1 Adam Williamson 2012-09-10 22:55:49 EDT
Created attachment 611633 [details]
package diff from tc5 to rc1

I loop mounted the images, did 'ls -R1 | grep rpm', and diffed the outputs.
Comment 2 Adam Williamson 2012-09-11 00:06:39 EDT
dgilmore found that he did the DVD/netinst spin with the wrong spin-kickstarts. we'll fire an RC2 with the correct ones quickly.
Comment 3 Adam Williamson 2012-09-11 13:19:06 EDT
This was caused by using the wrong spin-kickstarts for the DVD/netinst compose. It's fixed in RC2 by using the right one.

Note You need to log in before you can comment on or make changes to this bug.