Bug 856084 - Kernel panic while rebooting from VM
Kernel panic while rebooting from VM
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
Anush Shetty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 03:33 EDT by Anush Shetty
Modified: 2013-12-18 19:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 07:06:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel panic screenshot (82.82 KB, image/png)
2012-09-11 03:33 EDT, Anush Shetty
no flags Details

  None (edit)
Description Anush Shetty 2012-09-11 03:33:04 EDT
Created attachment 611679 [details]
Kernel panic screenshot

Description of problem: In RHEVM, we added a disk and increased memory of an existing VM. When the VM was started again, we saw a kernel panic.


Version-Release number of selected component (if applicable):

glusterfs-3.3.0rhsvirt1-2.el6_2.x86_64


How reproducible:

We don't have steps to reproduce


Steps to Reproduce:
1. Create a 2x2 Distributed-Replicated volume
2. Install the VM using RHS-2.0-20120503.1-RHS-x86_64-DVD1.iso
3. Shutdown the VM, add memory and disk
4. Start the VM
  
Actual results:

Kernel panic


Expected results:

Shouldn't panic

Additional info:
Comment 2 Amar Tumballi 2012-10-01 12:19:10 EDT
Anush, this doesn't look like a gluster issue... Can you confirm the behavior on backend FS itself?
Comment 3 Anush Shetty 2012-11-06 04:14:33 EST
Amar, how to try it directly on the backend FS? Should we try it on a VM hosted on a NFS export storage domain?
Comment 4 Amar Tumballi 2012-11-06 06:35:12 EST
Anush, yes, you can try it on NFS data store, also you can use backend FS directly using posixfs to mount a XFS volume (on /dev/sd*N)... But for verification, NFS data store is good enough.

Also as Yaniv mentioned in the call, it could have got fixed with later RHEV-H versions, as there was some similar bug there.
Comment 5 Anush Shetty 2012-11-07 06:32:14 EST
Unable to reproduce this issue with the latest build, glusterfs-3.3.0rhsvirt1-8.el6rhs.x86_64

Note You need to log in before you can comment on or make changes to this bug.