Bug 856088 - engine: cannot create a v3 domain when DC=none and host selected is from a 3.0 cluster but with vdsm-4.9.6
engine: cannot create a v3 domain when DC=none and host selected is from a 3....
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
medium Severity medium
: ---
: 3.1.0
Assigned To: Ayal Baron
Dafna Ron
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 03:48 EDT by Dafna Ron
Modified: 2016-02-10 11:51 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-14 15:12:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (139.90 KB, application/x-xz)
2012-09-11 03:48 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-09-11 03:48:02 EDT
Created attachment 611683 [details]
log

Description of problem:

I have a DC which is 3.0 in my setup and a host which is vdsm-4.9.6. 
Trying to create a V3 domain while host is still with cluster level 3.0 fails with CanDoAction even though DC was selected as None (which means it will not be attached to the pool) and vdsm version on the host can create a V3 domain. 

Version-Release number of selected component (if applicable):

si17

How reproducible:

100%

Steps to Reproduce:
1. create a 3.0 DC but update the host to vdsm-4.9.6
2. try to create a V3 domain with DC=None
3.
  
Actual results:

we get a CanDoAction: 

2012-09-11 10:16:04,732 WARN  [org.ovirt.engine.core.bll.storage.AddSANStorageDomainCommand] (ajp-/127.0.0.1:8009-9) [72055410] CanDoAction of action AddSANStorageDomain failed. Reasons:VAR__ACTION__ADD,VAR__TYPE__STORAGE__DOMAIN,ACTION_TYPE_FAILED_STORAGE_DOMAIN_FORMAT_ILLEGAL_HOST,$storageFormat V3

Expected results:

when creating a domain we query the db for cluster level of the host. 
we should change behaviour to check cluster level when DC=Pool but query selected host vdsm version when DC=none 

Additional info:logs
Comment 1 Ayal Baron 2012-09-11 08:41:33 EDT
DC = none is used to reinitialize DC and is based on the dc the host belongs to.
This is working as designed.
Comment 2 Dafna Ron 2012-09-11 09:03:52 EDT
1. reinitialise is done with an unattached domain. 
2. what if something happened during my compatibility change and I need a V3 domain to reinitialise? 
3. what if I, as the admin, would like to give a list of tasks to my employees which is to raise compatibility level and attach a new domain but I want them to use domains which I prepared for them since they don't have access to the storage? does that mean that they need to wake me up at night (since you do not do upgrades during the work day) so I can create the new domains after they raised compatibility? 

Adding need info to Simon.
Comment 3 Ayal Baron 2012-09-12 02:44:59 EDT
(In reply to comment #2)
> 1. reinitialise is done with an unattached domain. 
> 2. what if something happened during my compatibility change and I need a V3
> domain to reinitialise? 
> 3. what if I, as the admin, would like to give a list of tasks to my
> employees which is to raise compatibility level and attach a new domain but
> I want them to use domains which I prepared for them since they don't have
> access to the storage? does that mean that they need to wake me up at night
> (since you do not do upgrades during the work day) so I can create the new
> domains after they raised compatibility? 
> 
> Adding need info to Simon.

After you've raised the compatibility level of the DC then the action would be allowed.

Note You need to log in before you can comment on or make changes to this bug.