Bug 856108 - Redundant events about VLAN networks are reported to audit log
Redundant events about VLAN networks are reported to audit log
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Moti Asayag
GenadiC
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 04:32 EDT by Moti Asayag
Modified: 2016-02-10 14:57 EST (History)
8 users (show)

See Also:
Fixed In Version: SI19.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 15:06:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moti Asayag 2012-09-11 04:32:18 EDT
Description of problem:
An event-log is created for two types of VLAN network event-types:
1. For host which misses a network having vlan-tag.
2. For host with a vlan network out-of-sync with the vlan-id defined on the network on engine.

The first event is not relevant since is covered by the validation for a required network existence on host (regardless having vlan-tag)

The second event is already covered by the network-no-in-sync event.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
For event 1:
1. Create a network with vlan-id as non-required.
2. Perform any action via setupNetworks and check the event log.

For event 2:
1. Create a network with vlan-tag and attach to host.
2. Change manually the attached interface vlan-id.
3. Perform any action via setupNetworks not related to this interface so getCapabilities is invoked.
4. Check the events printed to the audit log.
  
Actual results:
event 1:
zeus02 is missing vlan id: 9 that is expected by the cluster
	
event 2:
zeus02 is having wrong vlan id: 5, expected vlan id: 222


Expected results:
The first event shouldn't be recorded.
Instead of the second event, the following message is expected in events-log:
Host zeus02's following network(s) are not synchronized with their Logical Network configuration: VLAN_MTU_5000.
Comment 1 Moti Asayag 2012-09-11 10:12:22 EDT
A suggested patch:

http://gerrit.ovirt.org/#/c/7923/
Comment 3 GenadiC 2012-10-02 09:56:40 EDT
Verified in SI19.1

Note You need to log in before you can comment on or make changes to this bug.