Bug 856109 - [rhev-gluster] add brick command should be blocked by can_do_action with list of checks before execution
[rhev-gluster] add brick command should be blocked by can_do_action with list...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kanagaraj
RamaKasturi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 04:33 EDT by Haim
Modified: 2016-04-18 06:05 EDT (History)
10 users (show)

See Also:
Fixed In Version: qa10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:26:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12612 None None None Never
oVirt gerrit 13239 None None None Never

  None (edit)
Description Haim 2012-09-11 04:33:31 EDT
Description of problem:

1) create new volume
2) add brick with dir node:/test
3) create volume
4) create new volume
5) add new brick with path node:test

actual results:

able to execute the action

expected:

should fail before execution to vdsBroker.


2012-09-11 11:20:16,768 INFO  [org.ovirt.engine.core.bll.gluster.CreateGlusterVolumeCommand] (ajp--0.0.0.0-8009-11) [7d878d1] Running command: CreateGlusterVolumeCommand internal: false. Entities affected :  ID: 99408929-82cf-4dc7-a532-9d998063fa95 Type: VdsGroups
2012-09-11 11:20:16,771 INFO  [org.ovirt.engine.core.vdsbroker.gluster.CreateGlusterVolumeVDSCommand] (ajp--0.0.0.0-8009-11) [7d878d1] START, CreateGlusterVolumeVDSCommand(vdsId = 2906ad06-f774-11e1-bb82-c3d9b0125c39), log id: 2751bc3d
2012-09-11 11:20:16,897 INFO  [org.ovirt.engine.core.vdsbroker.gluster.CreateGlusterVolumeVDSCommand] (ajp--0.0.0.0-8009-11) [7d878d1] FINISH, CreateGlusterVolumeVDSCommand, log id: 2751bc3d
Comment 2 RamaKasturi 2013-03-20 07:11:06 EDT
There are two scenarios in same brick can be added to the volume.

1) Create a volume and then try creating another volume with the same bricks in as in the first volume - scenario1

2) After creating the volume and then clicking on the add bricks link in the bricks tab. - scenario2

The fix in qa8 build has been done for the second scenario and not for the first scenario. so assigning it back.

Thanks 
kasturi.
Comment 3 Scott Haines 2013-09-23 18:26:05 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.