Bug 856121 - [rhev-gluster] remove bricks doesn't clean brick metadata and brick is not usable
[rhev-gluster] remove bricks doesn't clean brick metadata and brick is not us...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Amar Tumballi
Prasanth
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 05:01 EDT by Haim
Modified: 2014-01-12 19:54 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: volume start creates '.glusterfs' directory in backend export directory. in remove-brick, we don't do operations on backend export, but just change the volume configs to remove the brick... Consequence: stale data is present in backend export. Workaround (if any): perform a 'rm -rf /export-dir' on server node for cleanup.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 04:59:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine and gluster logs. (1.04 MB, application/x-tar)
2012-09-11 05:03 EDT, Haim
no flags Details

  None (edit)
Description Haim 2012-09-11 05:01:08 EDT
Description of problem:

1) create volume
2) create brick
3) start volume
4) stop volume
5) remove brick

check node:/brick_dir/

[root@filer01 ~]# ls -la /export/hateya2/
total 4
drwxr-xr-x   3 vdsm kvm    23 Sep 10 02:42 .
drwxr-xr-x. 11 root root 4096 Sep 11 02:47 ..
drw-------   8 root root   60 Sep 10 02:40 .glusterfs
Comment 2 Haim 2012-09-11 05:03:55 EDT
Created attachment 611695 [details]
engine and gluster logs.
Comment 3 Shireesh 2012-09-25 11:01:14 EDT
This is the glusterfs behavior, hence changing the product to RHS. AFAIK, this is intended behavior in glusterfs.
Comment 4 Amar Tumballi 2012-09-25 11:06:29 EDT
as of today, yes, it is a know behavior and not removing the brick from backend is intentional. One has to do a 'rm /brick-dir' on the server machine to make the proper cleanup.
Comment 5 Amar Tumballi 2012-10-09 04:37:36 EDT
proposing it to be known issues section. we think a proper cleanup of volume export dir will cause problems...
Comment 6 Amar Tumballi 2012-10-17 09:27:57 EDT
We will plan to support it in future with 'force' key... for now, recommend known-issues section in doc.
Comment 7 Amar Tumballi 2012-12-18 04:59:57 EST
Marked for known issues. (and the work around exists)

----------
Cause: 
volume start creates '.glusterfs' directory in backend export directory. in remove-brick, we don't do operations on backend export, but just change the volume configs to remove the brick...

Consequence: 
stale data is present in backend export.

Workaround (if any): 
perform a 'rm -rf /export-dir' on server node for cleanup.
------------

Please re-open if its not sufficient.

Note You need to log in before you can comment on or make changes to this bug.