Bug 856135 - [engine-core] During deleting action multiple floating disks and restart ovirt-engine service action disks get locked status
[engine-core] During deleting action multiple floating disks and restart ovir...
Status: CLOSED DUPLICATE of bug 856203
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: 3.1.5
Assigned To: Ayal Baron
vvyazmin@redhat.com
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 05:25 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 13:04 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 08:15:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs vdsm, rhevm, screen-shots (2.75 MB, application/x-gzip)
2012-09-11 05:25 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2012-09-11 05:25:08 EDT
Created attachment 611707 [details]
## Logs vdsm, rhevm, screen-shots

Description of problem: 
During deleting action multiple floating disks and restart ovirt-engine service action disks get locked status


Version-Release number of selected component (if applicable):
RHEVM 3.1 - SI17 

RHEVM: rhevm-3.1.0-15.el6ev.noarch 
VDSM: vdsm-4.9.6-32.0.el6_3.x86_64 
LIBVIRT: libvirt-0.9.10-21.el6_3.4.x86_64 
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.295.el6_3.2.x86_64 
SANLOCK: sanlock-2.3-3.el6_3.x86_64

How reproducible:
Occasionally

Steps to Reproduce:
1. Create 10 floating disk
2. Select them all, and delete
3. During deleting restart “ovirt-engine” service
  
Actual results:
Same disk get “Locked” status
No option delete them

Expected results:
No “Locked” disks
Option remove (delete them) them 

Additional info:
# psql -U postgres engine -c 'select disk_id,disk_alias,imagestatus  from all_disks where imagestatus = 2;'  | less -S 

               disk_id                | disk_alias | imagestatus 
--------------------------------------+------------+-------------
 c5cc119c-f9d0-4d54-a5c6-f9e24ba7194e | 1          |           2

# psql -U postgres engine -c 'select * from async_tasks;'  | less -S 

 task_id | action_type | status | result | action_parameters | action_params_class | step_id | command_id 
---------+-------------+--------+--------+-------------------+---------------------+---------+------------
(0 rows)
Comment 1 vvyazmin@redhat.com 2012-09-11 08:33:25 EDT
In DB “async_tasks” table: no tasks are running
In VDSM (vdsClient -s 0 getAllTasksInfo) : no tasks are running
In DB “all_disks” table, disk have status: imagestatus == 2
Comment 3 vvyazmin@redhat.com 2012-10-09 08:15:23 EDT

*** This bug has been marked as a duplicate of bug 856203 ***

Note You need to log in before you can comment on or make changes to this bug.