Bug 856209 - Use vgchange -aay in rc.sysinit and netfs init script
Use vgchange -aay in rc.sysinit and netfs init script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts (Show other bugs)
6.4
All Linux
high Severity medium
: rc
: ---
Assigned To: Lukáš Nykrýn
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 08:58 EDT by Peter Rajnoha
Modified: 2016-11-25 08:00 EST (History)
5 users (show)

See Also:
Fixed In Version: initscripts-9.03.32-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Calling vgchange -a y instead of vgchange -a ay in sysinit and netfs Consequence: All volumes were activated Fix: Call vgchange -a ay Result: With this setting, only the volumes that are declared to be activate are actually activated (see also rhbz #817866). If the list is not declared, all volumes are activated by default (which is the classic old way).
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:26:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lvm patch (1.33 KB, patch)
2012-09-11 10:07 EDT, Lukáš Nykrýn
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 381313 None None None Never

  None (edit)
Description Peter Rajnoha 2012-09-11 08:58:26 EDT
lvm2-2.02.97-2.el6 and higher contains code that supports auto-activation feature and "activation/auto_activation_volume_list" declared in lvm.conf. With this setting, only the volumes that are declared to be activate are actually activated (see also rhbz #817866). If the list is not declared, all volumes are activated by default (which is the classic old way).

For this feature to work correctly on boot as well, we need initscripts (the /etc/rc.sysinit and /etc/init.d/netfs script) to call:
 
    vgchange --sysinit -a ay

(instead of former "vgchange --sysinit -a y", the extra "a" in "-a ay" meaning "AutoActivate").

Since lower versions of lvm2 do not understand the new setting/activation scheme, we need initscripts to declare a proper dependency on this new lvm2 version in the spec file as well.
Comment 1 Lukáš Nykrýn 2012-09-11 10:07:31 EDT
Created attachment 611775 [details]
lvm patch
Comment 8 errata-xmlrpc 2013-02-21 05:26:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0518.html

Note You need to log in before you can comment on or make changes to this bug.