Bug 856228 - Shortcut for opening list of blockable items Ctrl+Shift+U is taken by GTK+
Shortcut for opening list of blockable items Ctrl+Shift+U is taken by GTK+
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: mozilla-adblockplus (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Russell Golden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 09:55 EDT by Tobias Mueller
Modified: 2012-09-11 17:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 16:09:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Mueller 2012-09-11 09:55:38 EDT
The keyboard shortcut of Adblock Plus to list items to block has changed recently from Ctrl+Shift+V to Ctrl+Shift+U. This is annoying, because that shortcut is taken by GTK+ to input any unicode codepoint.

I expected to be able to open the list of blockable items with a shortcut.
Comment 1 Russell Golden 2012-09-11 10:35:38 EDT
I will forward this upstream.
Comment 2 Russell Golden 2012-09-11 16:09:06 EDT
Upstream's response:

>Unfortunately, detecting that a keyboard shortcut is taken by GTK isn't possible. And keyboard shortcuts that are left unassigned are way too few to replace Ctrl-Shift-U by something else. So this is most likely something that I can't fix - you can change the hotkey in your installation however.

Looks like you're out of luck, bud. Sorry.
Comment 3 Tobias Mueller 2012-09-11 17:23:06 EDT
uh.
Well, it doesn't only put me off, but all the people that run adblock plus with GTK+. So that's barring all GNU/Linux users from accessing that window quickly. I consider that quite a bold move. And FWIW: GTK+ is using that shortcut for as long as I can remember. So it's not about "detecting whether that shortcut is taken by GTK", one can really assume that.

As I've said, it used to be Ctrl+Shift+V and AFAICS this shortcut is now not taken. Neither seems Ctrl+Shift+B. Nor Ctrl+Shift+C. At least they don't produce visible effects on my installations.

So I guess I'll try to change it back to Ctrl+Shift+V on my installations, but it'd obviously be cool if I didn't have to do it everytime I do a new installation somewhere.

Anyway, I appreciate your efforts, thanks.

Note You need to log in before you can comment on or make changes to this bug.