Bug 856259 - webadmin: we do not close the UI dialogue when sending UpgradeStoragePoolVDSCommand and get time out although command succeeds
webadmin: we do not close the UI dialogue when sending UpgradeStoragePoolVDSC...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
x86_64 Linux
high Severity high
: ---
: 3.1.0
Assigned To: Asaf Shakarchi
Dafna Ron
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 10:59 EDT by Dafna Ron
Modified: 2016-02-10 11:59 EST (History)
11 users (show)

See Also:
Fixed In Version: SI24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log and screenshot (326.60 KB, application/x-gzip)
2012-09-11 10:59 EDT, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2012-09-11 10:59:44 EDT
Created attachment 611807 [details]
log and screenshot

Description of problem:

when we raise DC compatibility level the dialogue is not closing and if operation takes a while (for example if you have more than 6 domains) we get a time out in UI allthough the operation returns successful. 

2012-09-11 11:39:57,501 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.UpgradeStoragePoolVDSCommand] (ajp-/127.0.0.1:8009-7) [74fc9ce1] START, UpgradeStoragePoolVDSCommand(storagePoolId = 854f5121-8550-4582-bb73-fce7d57a569c, poolVers
ion = 3), log id: 3e2363a4

2012-09-11 11:42:56,152 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.UpgradeStoragePoolVDSCommand] (ajp-/127.0.0.1:8009-7) [74fc9ce1] FINISH, UpgradeStoragePoolVDSCommand, log id: 3e2363a4


Version-Release number of selected component (if applicable):

si17

How reproducible:

100%

Steps to Reproduce:
1. create a 3.0 DC with 8 domains and raise to 3.1
2.
3.
  
Actual results:

we get a timeout from UI because dialogue is not closing after we sent the command to vdsm. 

Expected results:

we should close the dialogue after command is sent. 

Additional info: screen shot and engine log
Comment 2 Asaf Shakarchi 2012-10-28 08:42:57 EDT
Patch submitted:
http://gerrit.ovirt.org/#/c/8862/
Comment 3 Allon Mureinik 2012-10-29 03:34:15 EDT
Merged I0490c885603e5bf31300c1f7626eed8256da8711
Comment 4 Dafna Ron 2012-11-13 04:11:01 EST
verified on si24.1
the dialogue closes right away.

Note You need to log in before you can comment on or make changes to this bug.