Bug 856270 - [abrt] blueman-1.23-3.fc18: __init__.py:360:__init__:OSError: libpulse-mainloop-glib.so.0: cannot open shared object file: No such file or directory
[abrt] blueman-1.23-3.fc18: __init__.py:360:__init__:OSError: libpulse-mainlo...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
AcceptedNTH abrt_hash:98e26381685dbbb...
: Reopened
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept F18Xfce
  Show dependency treegraph
 
Reported: 2012-09-11 11:23 EDT by Daniel Greeley
Modified: 2013-01-08 16:33 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 16:33:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (624 bytes, text/plain)
2012-09-11 11:23 EDT, Daniel Greeley
no flags Details

  None (edit)
Description Daniel Greeley 2012-09-11 11:23:23 EDT
Version-Release number of selected component:
blueman-1.23-3.fc18

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python /usr/bin/blueman-applet
kernel:         3.6.0-0.rc4.git2.1.fc18.x86_64

backtrace:
:__init__.py:360:__init__:OSError: libpulse-mainloop-glib.so.0: cannot open shared object file: No such file or directory
:
:Traceback (most recent call last):
:  File "/usr/bin/blueman-applet", line 125, in <module>
:    BluemanApplet()
:  File "/usr/bin/blueman-applet", line 68, in __init__
:    self.Plugins.Load()
:  File "/usr/lib/python2.7/site-packages/blueman/main/PluginManager.py", line 98, in Load
:    __import__(self.module_path.__name__ + ".%s" % plugin, None, None, [])
:  File "/usr/lib/python2.7/site-packages/blueman/plugins/applet/PulseAudio.py", line 24, in <module>
:    from blueman.main.PulseAudioUtils import PulseAudioUtils, EventType
:  File "/usr/lib/python2.7/site-packages/blueman/main/PulseAudioUtils.py", line 7, in <module>
:    libpulse_glib = CDLL("libpulse-mainloop-glib.so.0")
:  File "/usr/lib64/python2.7/ctypes/__init__.py", line 360, in __init__
:    self._handle = _dlopen(self._name, mode)
:OSError: libpulse-mainloop-glib.so.0: cannot open shared object file: No such file or directory
:
:Local variables in innermost frame:
:_FuncPtr: <class 'ctypes._FuncPtr'>
:handle: None
:name: 'libpulse-mainloop-glib.so.0'
:use_last_error: False
Comment 1 Daniel Greeley 2012-09-11 11:23:25 EDT
Created attachment 611822 [details]
File: core_backtrace
Comment 2 Joachim Backes 2012-09-13 06:02:55 EDT
Happened after firstboot and first xfce login after F18 installation

Package: blueman-1.23-3.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 3 David Timms 2012-09-14 06:30:04 EDT
Fresh install of F18alpha
LXDE desktop
crash after first login.


Package: blueman-1.23-3.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 4 David Timms 2012-09-14 09:00:47 EDT
In F17:
yum whatprovides  libpulse-mainloop-glib.so.0
...
pulseaudio-libs-glib2-1.1-9.fc17.i686 : GLIB 2.x bindings for PulseAudio clients
Repo        : fedora
Matched from:
Provides    : libpulse-mainloop-glib.so.0

but not present on the lxde install.
Comment 5 htserv 2012-09-29 05:49:52 EDT
Initial install - first login threw the error.

Package: blueman-1.23-3.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 6 Jindrich Novy 2012-10-19 04:11:56 EDT
Started XFCE session on freshly installed F18 TC4 beta

Package: blueman-1.23-3.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 7 smatula 2012-11-01 10:07:32 EDT
Started XFCE session on freshly installed F18 TC6 beta

Package: blueman-1.23-4.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 8 Christian Kalkhoff 2012-12-27 05:48:03 EST
blueman package needs to depend on pulseaudio-libs-glib2. Or the runtime dependency gets dropped if no pulseaudio support is installed.

Ran into this regression after I installed F18 LXDE Desktop  without any addons from DVD (Beta). 

My system is latest updates-testing by Dec 26th 2012. Installing pulseaudio-libs-glib2 fixes the regression.
Comment 9 Fedora Update System 2012-12-27 14:34:30 EST
blueman-1.23-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/blueman-1.23-5.fc18
Comment 10 Fedora Update System 2012-12-27 14:35:17 EST
blueman-1.23-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/blueman-1.23-5.fc17
Comment 11 Christoph Wickert 2012-12-27 14:40:02 EST
I hereby propose this update for NTH because
- it affects (at least) the Xfce spin and LXDE users
- we have a fix
- the fix is trivial, packaging only.
- this package is python, we don't need to worry about introducing new odds with the new build.
Comment 12 Fedora Update System 2012-12-27 22:52:41 EST
Package blueman-1.23-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing blueman-1.23-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-21041/blueman-1.23-5.fc17
then log in and leave karma (feedback).
Comment 13 Adam Williamson 2013-01-02 14:55:18 EST
Discussed at 2013-01-02 NTH review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2013-01-02/f18final-blocker-review-8.2013-01-02-17.03.log.txt . Accepted as NTH: this would be a blocker issue for blocking desktops, so NTH for non-blocking desktops (see comment #11).
Comment 14 Fedora Update System 2013-01-05 01:33:02 EST
blueman-1.23-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Christoph Wickert 2013-01-05 12:27:13 EST
(In reply to comment #13)
> Accepted as NTH: this would be a
> blocker issue for blocking desktops, so NTH for non-blocking desktops

Thanks. I submitted the update for stable. Anything else I need to do to make sure it actually gets included in the release?
Comment 16 Fedora Update System 2013-01-08 16:33:53 EST
blueman-1.23-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.